IE8不支持写的兄弟选择器的解决方法?-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

IE8不支持写的兄弟选择器的解决方法?

想给图中高亮的标签加样式,但是直接加l-constrained不行,因为下边的div.lmain上也有一个那样的类名,
而且项目的代码是程序自动生出,我不能进行改动。用+都写好了,但是在IE8上无法使用,不知有没有好的解决办法?
screenshot

展开
收起
杨冬芳 2016-05-31 18:48:09 1680 0
1 条回答
写回答
取消 提交回答
  • 杨冬芳
    IT从业

    相邻兄弟选择器(+)从IE7+就开始支持了
    screenshot
    (section-header和I-header间如果没有空格)是选择同时有类section-header和I-header的元素后紧邻的元素,但从你的DOM结构截图中,并没有符合条件的。

    2019-07-17 19:22:23
    赞同 展开评论 打赏
问答排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载