限制应用只能在lED设备上跑 -问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

限制应用只能在lED设备上跑

2016-03-23 10:28:56 1453 1

开发了一个手电筒应用。我想添加限制,让应用只在带有LED的设备上运行。

准备用UIDeviceRequiredCapabilities,但是不知道具体用哪个键值?

取消 提交回答
全部回答(1)
  • 爵霸
    2019-07-17 19:10:26
    AVCaptureDevice *flashLight = [AVCaptureDevice defaultDeviceWithMediaType:AVMediaTypeVideo];
    
     //手电筒是否可用
     [flashLight isTorchAvailable];
    
     //是否至此某模式
     [flashLight isTorchModeSupported:AVCaptureTorchModeOn];
    
     //手电筒是否已经开启
     [flashLight isTorchActive];
    0 0
+关注
2
文章
9426
问答
问答排行榜
最热
最新
相关电子书
更多
JS零基础入门教程(上册)
立即下载
性能优化方法论
立即下载
手把手学习日志服务SLS,云启实验室实战指南
立即下载