【漏洞公告】CVE-2017-7494:Samba远程代码执行漏洞-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

【漏洞公告】CVE-2017-7494:Samba远程代码执行漏洞

正禾 2017-05-25 08:45:13 4881
2017年5月24日Samba发布了4.6.4版本,中间修复了一个严重的远程代码执行漏洞,漏洞编号为CVE-2017-7494,漏洞影响了Samba 3.5.0 和包括4.6.4/4.5.10/4.4.14中间的版本。
具体详情如下:                                 
                              
漏洞编号:
CVE-2017-7494
漏洞名称:
CVE-2017-7494:Samba远程代码执行漏洞
官方评级:
高危
漏洞描述:
该漏洞需要通过一个可写入的Samba用户权限就可以提权到samba所在服务器的root权限(samba默认是root用户执行的),该漏洞影响了Samba 3.5.0 和包括4.6.4/4.5.10/4.4.14中间的版本。
漏洞利用条件和方式:
直接远程利用
漏洞影响范围:
Samba 3.5.0之前所有版本、4.6.4、4.5.10、4.4.14
漏洞检测:
检测在用Samba 是否在受影响版本内
漏洞修复建议(或缓解措施):
  • 缓解措施:用户可以通过在smb.conf的[global]节点下增加 nt pipe support = no 选项,然后重新启动samba服务, 以此避免被利用
  • 根治措施:
  • 使用源码安装的Samba用户,请尽快下载最新的Samba版本手动更新;
  • 使用二进制分发包(RPM等方式)的用户立即进行yum,apt-get update等安全更新操作。

情报来源:
  • https://www.samba.org/samba/security/CVE-2017-7494.html
  • https://www.reddit.com/r/netsec/comments/6d0tfx/samba_cve20177494_remote_code_execution_from_a/
















安全 Windows
分享到
取消 提交回答
全部回答(2)
  • 正禾
    2017-05-31 09:19:38
    回 1楼(思丞) 的帖子
    https://mirrors.aliyun.com/centos/6.9/updates/x86_64/Packages/
    阿里云官方源也是根据厂商自动同步,跟官方源没有什么区别。默认配置就可以升级更新了,您可以试试。
    0 0
  • 思丞
    2017-05-26 10:49:15
    Re【漏洞公告】CVE-2017-7494Samba远程代码执行漏洞
    请问哪个yum源有最新的版本?
    0 0
添加回答
+ 订阅

云安全开发者的大本营

推荐文章
相似问题
推荐课程