找不到yunos/test/uiautomator/UiSelector模块-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

找不到yunos/test/uiautomator/UiSelector模块

游客toppf3dtawccq 2019-02-27 18:09:23 1251

- Error: Cannot find module 'yunos/test/uiautomator/UiSelector'
-     at Function.Module._resolveFilename (internal/modules/cjs/loader.js:581:15)
-     at Function.Module._load (internal/modules/cjs/loader.js:507:25)
-     at Module.require (internal/modules/cjs/loader.js:637:17)
-     at require (internal/modules/cjs/helpers.js:22:18)
-     at Object.<anonymous> (/Users/vbmwn/yunos_samples/1_UIAutomator/test/plover/testUiSelector.js:3:20)
-     at Module._compile (internal/modules/cjs/loader.js:689:30)
-     at Object.Module._extensions..js (internal/modules/cjs/loader.js:700:10)
-     at Module.load (internal/modules/cjs/loader.js:599:32)
-     at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
-     at Function.Module._load (internal/modules/cjs/loader.js:530:3)
- runner.done => code = 1
我在AliOS Studio中导入样例项目:1_UIAutomator
运行Main.js没有问题,但是运行testMain.js一直提示找不到 'yunos/test/uiautomator/UiSelector'模块,报错如上。
请问这是什么原因?是   [font="]yunos.test.uiautomator   API无法使用了吗?
物联网 API
分享到
取消 提交回答
全部回答(2)
  • 游客toppf3dtawccq
    2019-02-28 10:58:27
    回 1楼yarx的帖子
    你好,更新Emulator之后,只有一个lite模拟器能用,其余的vehicle、phone、adv等模拟器都无法运行,报错:分别是:设备类型未验证 和 缺少 system image。请问这个问题怎么解决?
    不更新的话,APILevel是 yunos-1,此时vehicle模拟器上的斑马系统是1.2.0版本。请问如何将模拟器上的斑马系统升级到2.0?

    -------------------------

    更新Emulator之后,模拟器无法使用的问题
    你好,更新Emulator之后,只有一个lite模拟器能用,其余的vehicle、phone、adv等模拟器都无法运行,报错:分别是:设备类型未验证 和 缺少 system image。请问这个问题怎么解决?报错图片我放在下一楼了。
    不更新的话,APILevel是 yunos-1,此时vehicle模拟器上的斑马系统是1.2.0版本。请问如何将模拟器上的斑马系统升级到2.0?
    0 0
  • yarx
    2019-02-27 19:40:40
    亲 您的测试脚本是在PC端直接执行的吗?
    uiautomator是设备端的工具,不是在pc上用的
    详情请参照这里:
    https://developer.alios.cn/#/%2Fdevelop%2F3_Developer_Tools%2F1_IDE%2Ftest?docversion=0

    https://developer.alios.cn/#/%2Fdevelop%2F3_Testing_Tools%2F1_UIAutomator?docversion=0

    0 0
添加回答
IoT
使用钉钉扫一扫加入圈子
+ 订阅

物联网软硬件开发者一站式基地

推荐文章
相似问题