新手看过来之-搭建PHP环境一键安装LNMP版本-已验证-附截图-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

新手看过来之-搭建PHP环境一键安装LNMP版本-已验证-附截图

ap1253j8y 2017-03-13 11:14:22 2769
系统需求:
  • CentOS/RHEL/Fedora/Debian/Ubuntu/Raspbian Linux系统
  • 需要5GB以上硬盘剩余空间
  • 需要128MB以上内存(如果为128MB的小内存VPS,Xen的需要有SWAP,OpenVZ的至少要有128MB以上的vSWAP或突发内存),注意小内存请勿使用64位系统!
  • 安装MySQL 5.6或5.7及MariaDB 10必须1G以上内存!。
  • VPS或服务器必须已经联网,且必须设置的是网络源不能是光盘源,同时VPS/服务器 DNS要正常!
  • Linux下区分大小写,输入命令时请注意!

LNMP一键安装包 V1.3 已经在 PhotonVPSVultr遨游主机OneAsiahost新加坡VPS搬瓦工BudgetVM、、 DigitalOceanLocVPSLinodeDiaHosting瑞豪开源KVMLA景文互联RamNodeHostigationBuyVM80VPSXSVPSHostUS快易互联阿里云等众多VPS的CentOS 5-7、RHEL 6-7、Fedora 21-23、Debian 7-8、Ubuntu 10.04-16.04的32位和64位系统上测试通过。
[backcolor=transparent]安装步骤:
1、使用putty或类似的SSH工具登陆VPS或服务器;

登陆后运行: screen -S lnmp

如果提示screen: command not found 命令不存在可以执行:yum install screen 或 apt-get install screen安装,详细内容参考 screen教程

2、下载并安装LNMP一键安装包:

您可以选择使用下载版(推荐美国及海外VPS或空间较小用户使用)或者完整版(推荐国内VPS使用,国内用户可用在 下载中找国内下载地址替换),两者没什么区别,只是完整版把一些需要的源码文件预先放到安装包里。

安装LNMP稳定版
wget -c http://soft.vpser.net/lnmp/lnmp1.3-full.tar.gz && tar zxf lnmp1.3-full.tar.gz && cd lnmp1.3-full && ./install.sh [backcolor=transparent]lnmp

安装LNMP测试版
wget -c http://soft.vpser.net/lnmp/lnmp1.4beta.tar.gz && tar zxf lnmp1.4beta.tar.gz && cd lnmp1.4 && ./install.sh [backcolor=transparent]lnmp

默认安装lnmp可不写,如需要安装LNMPA或LAMP,将./install.sh 后面的参数替换为[backcolor=transparent] lnmpa或[backcolor=transparent] lamp即可。如需更改网站和数据库目录先修改 lnmp.conf 文件。

如下载速度慢请更换其他下载节点,详情请看 下载页面LNMP下载节点具体替换方法

按上述命令执行后,会出现如下提示:

如果出现类似上图的提示,则表明安装失败,说明没有安装成功!!需要用 winscp或其他类似工具,将/root目录下面的lnmp-install.log下载下来,到 LNMP支持论坛发帖注明你的系统发行版名称及版本号、32位还是64位等信息,并将lnmp-install.log压缩以附件形式上传到论坛,我们会通过日志查找错误,并给予相应的解决方法。
默认LNMP是不安装FTP服务器的,如需要FTP服务器:https://lnmp.org/faq/ftpserver.html 5、添加、删除虚拟主机及伪静态管理 https://lnmp.org/faq/lnmp-vhost-add-howto.html 6、eAccelerator、xcache、memcached、imageMagick、ionCube、redis、opcache的安装 https://lnmp.org/faq/addons.html 7、LNMP相关软件目录及文件位置 https://lnmp.org/faq/lnmp-software-list.html 8、LNMP状态管理命令 https://lnmp.org/faq/lnmp-status-manager.html




  




Ubuntu 网络协议 NoSQL 关系型数据库 Linux BI Go 网络安全 Redis 虚拟化
分享到
取消 提交回答
全部回答(2)
  • ap1253j8y
    2017-03-16 14:14:52
    回 1楼(jesuiszb) 的帖子
    PHP的版本按安装的时候 是可以选的  
    0 0
  • 洵云
    2017-03-16 11:00:29
    这个nginx里的关于php的配置需要改吗?
    0 0
添加回答
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

推荐文章
相似问题