开发者社区> 问答> 正文

【漏洞公告】WordPress 任意文件删除漏洞

正禾 2018-06-28 11:39:57 13310
阿里云云盾应急响应中心监测到国外安全研究组织发布了一篇关于WordPress任意文件删除漏洞的预警文章,恶意攻击者可以利用该漏洞删除WordPress建站配置文件wp-config.php,从而导致界面进入网站安装页面。漏洞原因为WordPress程序 unlink() 函数在处理的用户输入传递给文件删除功能时,未进行适当判断处理,导致任意文件删除。


具体详情如下:
漏洞编号: N/A
漏洞名称: WordPress 任意文件删除
漏洞官方评级: 高危
漏洞描述: WordPress程序 unlink() 函数在处理的用户输入传递给文件删除功能时,未进行适当判断处理,导致任意文件删除。
漏洞利用条件和方式:
通过PoC直接远程利用。
PoC状态:
未公开
漏洞影响范围:
WordPress <= 4.9.6
漏洞检测:
开发 人员检查是否使用了受影响版本范围内的 版本。
漏洞修复建议(或缓解措施):
目前厂商还没有提供相关补丁,建议使用此软件的用户关注厂商的下载页以获取最新版本:
https://wordpress.org/download/

临时止血方案:
漏洞研究者提供了临时止血方案,可以在当前活动的主题/子主题的 functions.php 文件中添加如下内容:


add_filter( 'wp_update_attachment_metadata', 'rips_unlink_tempfix' );


function rips_unlink_tempfix( $data ) {
    if( isset($data['thumb']) ) {
        $data['thumb'] = basename($data['thumb']);
    }


    return $data;
}
注意:修复前请使用ECS快照功能进行备份。进行充分测试后进行修复。

情报来源:
  • https://blog.ripstech.com/2018/wordpress-file-delete-to-code-execution

弹性计算 安全
分享到
取消 提交回答
全部回答(1)
  • zhang45xiang
    2018-07-08 14:44:53
    Re【漏洞公告】WordPress 任意文件删除漏洞
    赶紧封堵啊;
    0 0
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

推荐文章
相似问题
推荐课程