开发者社区> 问答> 正文

Windows下Apache2.4PHP5.4下 https和openssl共存问题

yanonline 2017-12-23 14:19:11 1735
系统环境Win2008 32 +  Apache2.4+PHP5.4


最近业务影响,需要将apache 添加https服务,但发现添加后,原php的openssl函数不能正常调用,一调用apache服务就会自动重启。


我想主要是因为 Apache\bin下的
ssleay32.dll和libeay32.dll与PHP5 目录里的ssleay32.dll和libeay32.dll不一致引起


但我试过相互交换2个版本,或都使用同1版本都不行


请问各位大牛有什么好的解决办法!



Apache PHP Windows
分享到
取消 提交回答
全部回答(0)

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程