开发者社区> 问答> 正文

【漏洞公告】针对WebLogic T3协议反序列化漏洞补丁绕过

正禾 2018-05-10 15:12:03 8405
2018年4月27日,阿里云云盾应急响应中心监测到有针对WebLogic T3协议反序列化漏洞补丁绕过,通过此漏洞,攻击者可以在未授权的情况下远程执行代码。该漏洞为之前Oracle官方发布了4月份的关键补丁更新CPU(Critical Patch Update),但并没有起到完全修复效果。


漏洞名称:
WebLogic T3协议反序列化漏洞补丁绕过
影响软件:
WebLogic服务器核心组件(WLS Core Components)
风险评级:
针对"CVE-2018-2628"补丁绕过:高危
受影响范围:
  • WebLogic 10.3.6.0
  • WebLogic 12.1.3.0
  • WebLogic 12.2.1.2
  • WebLogic 12.2.1.3



解决方案:
如果您不依赖T3协议进行JVM通信,可通过暂时阻断T3协议缓解此漏洞带来的影响。
  • 进入Weblogic控制台,在base_domain配置页面中,进入“安全”选项卡页面,点击“筛选器”,配置筛选器;
  • 在连接筛选器中输入:weblogic.security.net.ConnectionFilterImpl,在连接筛选器规则框中输入:* * 7001 deny t3 t3s,保存生效(无需重启)。

目前官方暂未发布修复补丁,建议您持续关注和跟进。
安全 Oracle Java 关系型数据库 应用服务中间件
分享到
取消 提交回答
全部回答(1)
  • 送小孩
    2018-05-15 09:24:53
    Re【漏洞公告】针对WebLogic T3协议反序列化漏洞补丁绕过
    LZ休产假回来了,欢迎!欢迎!!
    0 0
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

推荐文章
相似问题