开发者社区> 问答> 正文

【漏洞公告】CVE-2017–1000405:Linux内核的Huge Dirty COW权限提升漏洞

正禾 2017-12-01 17:42:29 17588
2017年11月20日,Linux内核被爆出Huge Dirty COW漏洞,该漏洞是在去年发现的脏牛漏洞(CVE-2016–5195)尚未被完全修复而产生的新漏洞,该漏洞类型属于本地提权,非直接远程攻击,影响范围有限。
具体详情如下:
  

漏洞编号:
CVE-2017–1000405
漏洞名称:
Linux内核的Huge Dirty COW权限提升漏洞
官方评级:
中危
漏洞描述:
问题出现在get_user_pages函数中。 该函数用于获取用户进程中虚拟地址后面的物理页面。 调用者在使用时必须指定在这些页面上执行的动作,从而内存管理器可以准备相应的页面。而当调用者在私有映射内的页面上执行写入操作时,页面可能需要经历COW(写时复制)循环 ——当新页面可写时会将原始“只读”页面复制到新页面,而原始页面可能是具有“特权”的,由此造成了该漏洞
漏洞利用条件和方式:
本地提权利用。
PoC状态:
未公开
漏洞影响范围:
Linux Kernel版本为:2.6.38 - 4.14
阿里云提供的Ubuntu、CentOS及RHEL 5/6/7发行版本由于未引入漏洞代码,不受此漏洞影响。
漏洞检测:
查看(cat) /sys/kernel/mm/下的transparent_hugepage目录enabled文件,显示[always]则会有影响
漏洞修复建议(或缓解措施):
  • 本漏洞安全风险较低,升级内核风险较大,谨慎升级内核;
  • 关注官方发布的安全补丁。

情报来源:
  • https://medium.com/bindecy/huge-dirty-cow-cve-2017-1000405-110eca132de0
  • https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-1000405
  • http://www.openwall.com/lists/oss-security/2017/11/30/2














安全 Ubuntu Linux
分享到
取消 提交回答
全部回答(0)

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程