Vestacp如何让默认的php5.6降级到php5.2呢-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

Vestacp如何让默认的php5.6降级到php5.2呢

紫罗袍 2016-12-24 09:44:24 4000
受该帖 https://bbs.aliyun.com/read/254641.html的启发,在一个装有vestacp的vps中试装了一下php5.2没有成功,不知为啥


[root@ziluopao ~]# yum install php52 php52-gd php52-mbstring php52-mysql
Loaded plugins: security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php52.x86_64 0:5.2.17-1.el6 will be installed
--> Processing Dependency: php-common = 5.2.17-1.el6 for package: php52-5.2.17-1.el6.x86_64
--> Processing Dependency: php-cli = 5.2.17-1.el6 for package: php52-5.2.17-1.el6.x86_64
---> Package php52-gd.x86_64 0:5.2.17-1.el6 will be installed
---> Package php52-mbstring.x86_64 0:5.2.17-1.el6 will be installed
---> Package php52-mysql.x86_64 0:5.2.17-1.el6 will be installed
--> Running transaction check
---> Package php-pecl-zip.x86_64 0:1.13.5-1.el6.remi.5.6 will be obsoleted
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.6.29-1.el6.remi.x86_64
---> Package php52-cli.x86_64 0:5.2.17-1.el6 will be installed
---> Package php52-common.x86_64 0:5.2.17-1.el6 will be obsoleting
--> Running transaction check
---> Package php56-common.x86_64 0:5.6.12-1.el6 will be installed
--> Processing Conflict: php56-common-5.6.12-1.el6.x86_64 conflicts php-common < 5.5.0
--> Finished Dependency Resolution
Error: php56-common conflicts with php52-common-5.2.17-1.el6.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@ziluopao ~]#


安全
分享到
取消 提交回答
全部回答(2)
  • 紫罗袍
    2016-12-25 00:25:50
    ReVestacp如何让默认的php5.6降级到php5.2呢
    引用第1楼ivmmff于2016-12-24 10:56发表的  :
    需要卸载5.6,并关闭remi [url=https://bbs.aliyun.com/job.php?action=topost&tid=303148&pid=852454][/url]

    怎么安装呢
    0 0
  • 妙正灰
    2016-12-24 10:56:25
    需要卸载5.6,并关闭remi
    0 0
添加回答
+ 订阅

云安全开发者的大本营

推荐文章
相似问题
推荐课程