开发者社区> 问答> 正文

【漏洞公告】DNSMASQ多高危漏洞公告

正禾 2017-10-10 11:52:30 4726
DNSMASQ是一个小巧且方便地用于配置DNS和DHCP的工具,它提供了DNS功能和可选择的DHCP功能。在中小企业环境和云平台中被广泛使用,包括libvirt等在内组件都会直接使用它作为支撑。
2017年10月2日, 由Google安全团队发现的多个DNSMASQ安全漏洞被披露。其中漏洞编号为:CVE-2017-14491、CVE-2017-14492、CVE-2017-14493 的三个漏洞被相关厂商标记为严重等级,其他漏洞编号为:CVE-2017-14494、CVE-2017-14495、CVE-2017-14496、CVE-2017-13704的漏洞被标记为重要等级。


阿里云安全提醒使用DNSMASQ用户尽快排查和升级处理,防止发生安全事件。
具体漏洞详情如下:
      

漏洞编号:
CVE-2017-14491
CVE-2017-14492
CVE-2017-14493
CVE-2017-14494
CVE-2017-14495
CVE-2017-14496
CVE-2017-13704
漏洞名称:
DNSMASQ多高危漏洞公告
漏洞评级:
高危
漏洞描述:
受影响的dnsmasq服务遭受远程任意代码执行攻击或远程拒绝服务攻击,造成主机被入侵或服务不可用,存在安全风险。
漏洞影响范围:
CVE 漏洞等级 受影响版本
CVE-2017-14491 严重 所有版本
CVE-2017-14492 严重 2.60 - 2.66
CVE-2017-14493 严重 2.60 - 2.66
CVE-2017-14494 重要 2.60 - 2.66
CVE-2017-14495 重要 2.76
CVE-2017-14496 重要 2.76
CVE-2017-13704 重要 2.77

漏洞检测:
开发或运维人员检查使用的DNSMASQ软件是否在受影响版本范围内。
漏洞修复建议(或缓解措施):
  • 相关Linux发行厂商已经提供了安全更新,您可以通过 yum 或 apt-get 进行安全更新升级;

1.Ubuntu 14.04/16.04 LTS系列用户
Ubuntu 16.04 LTS系列:升级Dnsmasq到 2.75-1ubuntu0.16.04.3
Ubuntu 14.04 LTS系列:升级Dnsmasq到 2.68-1ubuntu0.2
1)sudo apt-get update && sudo apt-get install dnsmasq,进行Dnsmasq版本更新;
2)重启dnsmasq服务生效;


2.CentOS 6/7 系列用户
CentOS 7系列:升级Dnsmasq到 2.76-2.el7_4.2
CentOS 6系列:升级Dnsmasq到 2.48-18.el6_9

1)yum clean all && yum makecache,更新软件源;
2)yum -y update dnsmasq ,更新当前Dnsmasq版本;
3)重启dnsmasq服务生效;

情报来源:

















云安全 运维 安全 网络协议 Ubuntu Linux
分享到
取消 提交回答
全部回答(0)

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程