centos5.1.632位升级php-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

centos5.1.632位升级php

凌云劲竹 2015-05-31 22:14:13 8452
centos 5.1.6 32位升级php


centos 5.1.6 32位采用yum安装时  默认安装php 5.1.6版本
系统信息如下

# php -v
PHP 5.1.6 (cli) (built: Nov  6 2014 12:25:33)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies



# rpm -qa|grep php
php-common-5.1.6-45.el5_11
php-mysql-5.1.6-45.el5_11
php-ldap-5.1.6-45.el5_11
php-mbstring-5.1.6-45.el5_11
php-cli-5.1.6-45.el5_11
php-pdo-5.1.6-45.el5_11
php-bcmath-5.1.6-45.el5_11
php-xml-5.1.6-45.el5_11
php-dba-5.1.6-45.el5_11
php-gd-5.1.6-45.el5_11





现在大多数php开源系统和框架只支持5.2+版本


选择升级php到5.2+


百度了几个解决方案  都没有解决问题  比如
1  添加yum repo php5.2.x  然后  yum update
    实测  无效
    博文地址  http://www.bxl.me/6413.html


2  更新 /etc/yum.repos.d/CentOS-Base.repo 文件  然后  yum update
    实测  无效
    博文地址  http://blog.chinaunix.net/uid-21710705-id-3039680.html


这两者方法  都是通过修改yum repo来更新php
实测后  一样没有找到更新包  未完成升级操作


之后找到一篇博文  说可以通过编译php源码  达到升级目的
开始下载编译php源码  主要参考了以下博文
http://www.cnblogs.com/alexqdh/archive/2012/11/20/2776017.html
http://blog.chinaunix.net/uid-26719405-id-3409842.html


编译成功  安装目录

/usr/local/php
将其和其bin目录添加到PATH路径里   并卸载php老版本



# yum remove php
...
# php -v
PHP 5.1.6 (cli) (built: Nov  6 2014 12:25:33)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
.
# which php
/usr/bin/php



问题依然没有解决
php命令执行路径还是以前的


请教版本和达人  接下来应该怎么做才能替换成功


Linux PHP
分享到
取消 提交回答
全部回答(4)
  • denvor
    2015-06-02 18:35:33
    Recentos5.1.632位升级php
    这是 光卸载了 php , 没有卸载 php-cli 的原因。
    应该查看 已安装的php的所有模块:
    yum list installed  | grep php
    然后全部卸载这些含php 的。
    此时再进行源码安装。
    0 0
  • ballpen
    2015-06-01 23:42:48
    回 楼主(凌云劲竹) 的帖子
    有过成功案例     楼主方法不对
    0 0
  • 凌云劲竹
    2015-06-01 10:54:18
    Recentos5.1.632位升级php
    你好
    我也不清楚哪个环节忽略了
    现在我的主机上 php 命令执行的所在目录为 /usr/bin/
    # which php
    /usr/bin


    而我编译的 php 所在目录为 /usr/local/php
    # /usr/local/php/bin/php -v

    PHP 5.4.41 (cli) (built: May 31 2015 10:36:05)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies




    /usr/local/php目录结构如下

    # ls /usr/local/php/
    bin  etc  include  lib    php



    现在执行 php -v 结果还是 5.1.6

    -------------------------

    回1楼dongshan8的帖子
    请小二给我测试一下吧  谢谢

    -------------------------

    回4楼ballpen的帖子


    后来不知怎么搞的  apache 不能解析 php 文件了

    更换操作系统到 centos 6.5 64位 重新安装 apache php 就可以了

    php 也默认安装成了 5.4.1

    -------------------------

    回6楼dongshan8的帖子
    谢谢  :)

    -------------------------

    回7楼denvor的帖子
    原来如此  以后请多指教  谢谢
    0 0
  • dongshan8
    2015-05-31 22:58:03
    楼主您好,

    估计是哪个环节忽略了。

    如果明天您还没有解决问题,且需要小二为您测试,请回复一下这个楼层,我去找个centos 5来测试一下喔。

    -------------------------

    回 5楼(凌云劲竹) 的帖子
    楼主您好,

    看到您已经解决,很高兴喔。

    感谢您更新了帖子的状态。
    0 0
添加回答

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程