开发者社区> 问答> 正文

greenplum扩容计算节点时出的一个问题

精神院里病最重的人 2019-04-12 14:31:59 306

首先我执行扩容命令gpexpand seg_hosts -D test,然后报出如下错误:
QQ_20190412141529
当时看着一脸懵,就只知道失败了,想做回滚,然后gpexpand -r -D test,立马又是一个类似的错误,瞬间傻了:
QQ_20190412141958
然后非常粗略的看了下报错,以为是rsync没装(感觉就不是,但是死马当活马医了),然后yum -y install rsync:然后出现:
__20190412142400
接着我查了一下python的路径:
__20190412142520
然后我以为按照路径提示换了/usr/bin/yum第一行的解释器,换成了!#/usr/local/greenplum-db-5.9.0/ext/python/bin/python
然后说是坏的解释器,然后我疯了。。。。我只是做个扩容节点,咋给我牵扯出这么多东西!
小弟傻傻分析了一下,是不是因为greenplum我没安装python扩展导致,如果要装需要怎么装?小弟没做过这样的操作。
然后现在是yum不能用,数据回滚不了,用了gpstart -m/gpstart -R可以启动,但是就是回滚不了,然后gpstart启动不了!
各位大佬,救救小弟吧,感谢!!!

Python
分享到
取消 提交回答
全部回答(0)

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题