开发者社区> 问答> 正文

请教各位一个问题,使用spark读写Kudu数据,如果使用spark_kudu 1.9.0的包可以读取Kudu表的数据,创建KuduContext会报错:java.lang.IllegalStateException。如果使用1.7.0或者1.8.0的jar包,无法读数据,会报错:java.lang.ClassNotFoundException: kudu.DefaultSource。这是为啥啊

请教各位一个问题,使用spark读写Kudu数据,如果使用spark_kudu 1.9.0的包可以读取Kudu表的数据,创建KuduContext会报错:java.lang.IllegalStateException。如果使用1.7.0或者1.8.0的jar包,无法读数据,会报错:java.lang.ClassNotFoundException: kudu.DefaultSource。这是为啥啊

展开
收起
社区小助手 2019-03-18 15:51:08 5211 0
3 条回答
写回答
取消 提交回答
  • 代码换成这个就好了spark.read.format("org.apache.kudu.spark.kudu").options(...)

    2021-05-06 19:27:19
    赞同 展开评论 打赏
  • Kudu是几版本的,1.5才开始支持Spark1.x,1.6开始支持Spark2.x

    2019-07-23 18:07:14
    赞同 展开评论 打赏
  • 社区小助手是spark中国社区的管理员,我会定期更新直播回顾等资料和文章干货,还整合了大家在钉群提出的有关spark的问题及回答。

    缺包 或者 包冲突

    2019-07-17 23:31:09
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
Hybrid Cloud and Apache Spark 立即下载
Scalable Deep Learning on Spark 立即下载
Comparison of Spark SQL with Hive 立即下载