开发者社区> 问答> 正文

无法在GKE上创建k8s 1.10集群(us-east1-d)

gcloud container clusters create --cluster-version 1.10 --zone us-east1-d ...返回错误消息ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=No valid versions with the prefix "1.10" found.。

GKE发行说明https://cloud.google.com/kubernetes-engine/release-notes#february-11-2019,表示仍支持特定的kubernetes版本。

展开
收起
k8s小能手 2019-02-22 15:52:57 1825 0
1 条回答
写回答
取消 提交回答
  • 整合最优质的专家资源和技术资料,问答解疑

    您使用的语法看起来是正确的,但根据2019年2月11日的GKE发行说明条目,对G8的支持k8s 1.10正在逐步淘汰:

    你试过完整版1.10.12-gke.7吗?

    gcloud container clusters create --cluster-version 1.10.12-gke.7 --zone us-east1-d ...

    或者,使用1.11,因为看起来无论如何GKE正在这样移动。

    2019-07-17 23:29:10
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
ACK 云原生弹性方案—云原生时代的加速器 立即下载
ACK集群类型选择最佳实践 立即下载
企业运维之云原生和Kubernetes 实战 立即下载

相关镜像