开发者社区> 上进小菜猪> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

VRRP+MSTP配置详解【华为eNSP实验】

简介: VRRP+MSTP配置详解【华为eNSP实验】
+关注继续查看

@[toc]

一.前言

之前我们配置了MSTP,完成了一个基础的需求,现在我们继续来完善一下,使用VRRP+MSTP配置
需求如下:

某公司现有需求500台设备可以上到外网,该公司有5个部门,分别是A\B\C\D\E,
每个部门均需要100台设备,并要求二层进行隔离。
1.合理规划IP(使用私有IP)与子网。
2.拟采用DHCP下发地址(拓展)
3.划分VLAN,保障二层链路流量的控制。
5.公司网络需要在两台汇聚层交换机和一台核心路由器上配置ospf路由协议实现内部网络通信。
6、在两台汇聚层交换机之间需要做链路聚合来增加带宽,考虑到二层网络的安全问题和网络资源占用问题需要对不同部门间实现二层隔离。
7.现用5台二层交换机分别模拟5个部门的接入层设备。
8.为提高网络的可靠性,每台二层接入设备都需要和汇聚层设备进行互联, 所以需要配置STP协议在保证可靠的基础上防止环路的发生。(拓展)
9、为方便后期管理和维护需要在核心和汇聚层设备上开启远程登录功能。认证方式为用户名+密码认证(用户名和密码自定义)。
10.MSTP、VRRP这些技术同学们可根据情况加以考虑和实现。(拓展)
11.思考当内网用户需要访问互联网时如何实现?

1.1 MSTP

MSTP不仅涉及多个MST(生成树实例),而且可以划分为多个MST区域(MST区域,也称为MST区域)。通常,MSTP网络可以包含一个或多个MST域,每个MST域可以包含一个或多个MST。每个MSTI由运行stp/rstp/mstp的交换设备组成,这些交换设备通过mstp协议计算后形成树状网络。

1.2 VRRP

虚拟路由冗余协议VRRP(Virtual Router Redundancy Protocol)是一种用于提高网络可靠性的容错协议。通过VRRP,可以在主机的下一跳设备出现故障时,及时将业务切换到备份设备,从而保障网络通信的连续性和可靠性。

看一下拓扑图:在这里插入图片描述

三.实验过程

我们之前已经成功的配置了MSTP,那么我们需要注意一点:
因为我们的MSTP的

instance 1 root primary
instance 2 root secondary

vlan10 20 在主根在SW6,备根在SW7。
vlan30 40 50 主根在SW7,备根在SW6。
如下分配。

instance 1 vlan 10 20
instance 2 vlan 30 40 50

在这里插入图片描述

那么我们在配置的之后需要注意一点
VRRP中vlan 10 20走SW6,与上面相呼应
如下,我们先进入interface Vlanif10,配置ip地址

interface Vlanif10
ip address 192.168.10.124 25

使用VRRP配置虚拟路由,改优先级为150。

vrrp vrid 1 virtual-ip 192.168.10.126 vrrp vrid 1 priority 150 vrrp

同时设置上层链路检测,检测GigabitEthernet0/0/9接口,如果该接口故障或者丢包的话优先级减60。
这样的话,走SW7路线进行通信。

vrid 1 track interface GigabitEthernet0/0/9 reduced 60 dhcp select
global

其他的同理:
在这里插入图片描述
注意一点,在sw6和sw7的ip不能配置一样,否则容易冲突。
踩坑截图:
在这里插入图片描述
踩坑2:
在这里插入图片描述
配置完VRRP,全部都是主。
原因,Eth-Trunk1没有放行vlan vrrp:

interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
解决:
在这里插入图片描述
在这里插入图片描述

3.1 便捷命令

SW6为例:

interface Vlanif10
ip address 192.168.10.124 25
vrrp vrid 1 virtual-ip 192.168.10.126
vrrp vrid 1 priority 150
vrrp vrid 1 track interface GigabitEthernet0/0/9 reduced 60
dhcp select global
interface Vlanif20
ip address 192.112.20.252 25
vrrp vrid 2 virtual-ip 192.112.20.254
vrrp vrid 2 priority 150
vrrp vrid 2 track interface GigabitEthernet0/0/9 reduced 60
interface Vlanif40
 ip address 192.168.20.252 25
 vrrp vrid 4 virtual-ip 192.168.20.254

interface Vlanif30
 ip address 192.168.20.124 25
 vrrp vrid 3 virtual-ip 192.168.20.126

interface Vlanif50
 ip address 192.168.30.124 25
 vrrp vrid 5 virtual-ip 192.168.30.126

在这里插入图片描述

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
权威详解 | 阿里新一代实时计算引擎 Blink,每秒支持数十亿次计算
阿里巴巴需要研发世界级一流的流式计算引擎,实时处理海量数据,提供在线统计、学习和预测能力,不仅支持阿里巴巴自己的核心电商场景,同时也能通过阿里云向外部中小企业提供流式计算服务,输出实时计算能力,这就是我今天要分享的最新一代阿里巴巴实时计算引擎Blink。
2629 0
权威详解 | 阿里新一代实时计算引擎 Blink,每秒支持数十亿次计算
阿里巴巴需要研发世界级一流的流式计算引擎,实时处理海量数据,提供在线统计、学习和预测能力,不仅支持阿里巴巴自己的核心电商场景,同时也能通过阿里云向外部中小企业提供流式计算服务,输出实时计算能力,这就是我今天要分享的最新一代阿里巴巴实时计算引擎Blink。
18136 0
+关注
上进小菜猪
苟怀四方志,所在可游盘。技术很菜但不放弃
306
文章
7
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载