题目描述:
输入一行字符,以回车符作为输入结束的标志。统计其中英文字母、数字字符和其他字符的个数。
输入:
多个字符,以回车符结束,回车符不作为有效字符。有效字符个数不超过100。
输出:
输出分3行,格式见输出样例。
样例输入:
Abse 4+5*3=?
样例输出:
letter:4
digit:3
other:5
程序代码:
s=input() a=b=c=0 for ch in s : if ch.isalpha() : a+=1 elif ch.isdigit() : b+=1 else : c+=1 print("letter:%d" %(a)) print("digit:%d" %(b)) print("other:%d" %(c))