HDU-1048,The Hardest Problem Ever(字符串处理)

简介: HDU-1048,The Hardest Problem Ever(字符串处理)

Problem Description:


Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.

You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:


Cipher text

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Plain text

V W X Y Z A B C D E F G H I J K L M N O P Q R S T U


Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.


Input:


Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.


A single data set has 3 components:


Start line - A single line, "START"


Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar


End line - A single line, "END"


Following the final data set will be a single line, "ENDOFINPUT".


Output:


For each data set, there will be exactly one line of output. This is the original message by Caesar.


Sample Input:


START


NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX


END


START


N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ


END


START


IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ


END


ENDOFINPUT


Sample Output:


IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES


I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME


DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE


解题思路:


这道题就是说每组数据都是三行 ,从START开始,END结束,对26个英文字母进行处理,每一个字母都向前移动5个,一定要记住ASCII码,其中A到E是特殊情况,向前移动5个等于向后移动21个,其他21个字母均为正常情况。


程序代码:  


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int main()
{
  string str,start,end;
  while(getline(cin,start))
  {
    if(start=="START")
      getline(cin,str);
    if(start=="ENDOFINPUT")
      break;
    for(int i=0;i<str.length();i++)
    {
      if(str[i]>='A'&&str[i]<='Z')
      {
        if(str[i]>='A'&&str[i]<='E')
          str[i]+=21;
        else
          str[i]-=5;
      }
    }
    getline(cin,end);
    if(end=="END")
    {
      for(int i=0;i<str.length();i++)
        cout<<str[i];
      cout<<endl;
    }
  }
  return 0;
}
相关文章
|
24天前
|
算法 C++
POJ 3740 Easy Finding题解
这篇文章提供了一个使用舞蹈链(Dancing Links)算法解决POJ 3740 "Easy Finding" 问题的C++代码实现,该问题要求找出矩阵中能够使每一列都恰好包含一个1的行集合。
|
4月前
|
C语言
栈的问题:HDU—1022 Train Problem I(C语言)
栈的问题:HDU—1022 Train Problem I(C语言)
UVa12478 - Hardest Problem Ever (枚举)
UVa12478 - Hardest Problem Ever (枚举)
43 0
LeetCode contest 185 1417. 重新格式化字符串
LeetCode contest 185 1417. 重新格式化字符串
|
安全
HDU-1039,Easier Done Than Said?(字符串处理)
HDU-1039,Easier Done Than Said?(字符串处理)
|
测试技术
HDU-1228,A + B(字符串处理)
HDU-1228,A + B(字符串处理)
|
安全 数据安全/隐私保护
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
100 0
|
Java
HDOJ/HDU 1982 Kaitou Kid - The Phantom Thief (1)(字符串处理)
HDOJ/HDU 1982 Kaitou Kid - The Phantom Thief (1)(字符串处理)
105 0
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
129 0