HDU-1039,Easier Done Than Said?(字符串处理)

简介: HDU-1039,Easier Done Than Said?(字符串处理)

Problem Description:


Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.


FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:


It must contain at least one vowel.


It cannot contain three consecutive vowels or three consecutive consonants.


It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.


(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.


Input:


The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.


Output:


For each password, output whether or not it is acceptable, using the precise format shown in the example.


Sample Input:


a


tv


ptoui


bontres


zoggax


wiinq


eep


houctuh


end


Sample Output:


<a> is acceptable.


<tv> is not acceptable.


<ptoui> is not acceptable.


<bontres> is not acceptable.


<zoggax> is not acceptable.


<wiinq> is not acceptable.


<eep> is acceptable.


<houctuh> is acceptable.


解题思路:


就是一个字符串处理的题目,题目核心内容:


它必须至少包含一个元音。

它不能包含三个连续的元音或三个连续的辅音。

它不能包含两个连续出现的相同字母,但“ ee”或“ oo”除外。

(其中元音为'a','e','i','o'和'u';所有其他字母均为辅音。) 同时满足这三个条件则为acceptable。


我们可以定义三个标记变量去标记这三个条件,如果符合,改变对应标记变量的值就可以了。其他的我们一起看代码吧!


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
bool yuanyin(char a)//元音 
{
  if(a=='a'||a=='e'||a=='i'||a=='o'||a=='u')
    return true;
  return false;
}
int main()
{
  string s;
  while(cin>>s)
  {
    if(s=="end")//结束条件 
      break;
    int a=0,b=0;
    bool flag=false,ans=true,find=true;//flag标记第一个条件,ans标记第二个条件,find标记第三个条件 
    for(int i=0;i<s.size();i++)
    {
      if(yuanyin(s[i]))//字符串中有元音 
        flag=true;
      if(yuanyin(s[i]))//统计元音个数 
      {
        a++;
        b=0;
      }
      else//统计辅音个数 
      {
        b++;
        a=0;
      }
      if(a>=3||b>=3)//只要有一个大于等于3 
      {
        ans=false;
        break;
      }
      if(s[i]!='o'&&s[i]!='e'&&i>0)
      {//除了o和e,不能有连续两个相同的字母 
        if(s[i]==s[i-1])
        {
          find=false;
          break;
        }
      }
    }
    if(ans&&flag&&find)//对应格式化输出 
      cout<<"<"<<s<<">"<<" is acceptable."<<endl;
    else
      cout<<"<"<<s<<">"<<" is not acceptable."<<endl;
  }
  return 0;
}


相关文章
|
5月前
【practise】逆波兰表达式求值
【practise】逆波兰表达式求值
【practise】逆波兰表达式求值
|
8月前
|
C语言
UVA-537--Artificial Intelligence?(C语言)
UVA-537--Artificial Intelligence?(C语言)
|
8月前
|
C语言
栈的问题:HDU—1022 Train Problem I(C语言)
栈的问题:HDU—1022 Train Problem I(C语言)
UVa10776 - Determine The Combination(有重复元素的组合问题)
UVa10776 - Determine The Combination(有重复元素的组合问题)
49 0
UCF 2021 Practice F.Balanced Strings (思维 组合数学)
UCF 2021 Practice F.Balanced Strings (思维 组合数学)
109 0
HDU-1048,The Hardest Problem Ever(字符串处理)
HDU-1048,The Hardest Problem Ever(字符串处理)
|
测试技术
HDU-1228,A + B(字符串处理)
HDU-1228,A + B(字符串处理)
|
安全 数据安全/隐私保护
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
111 0
|
Java
HDOJ/HDU 1982 Kaitou Kid - The Phantom Thief (1)(字符串处理)
HDOJ/HDU 1982 Kaitou Kid - The Phantom Thief (1)(字符串处理)
120 0

热门文章

最新文章