POJ-1308,Is It A Tree?(并查集和树)

简介: POJ-1308,Is It A Tree?(并查集和树)

Description:


A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.


There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

网络异常,图片无法展示
|




In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.  


Input:


The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.  


Output:


For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).  


Sample Input:


6 8 5 3 5 2 6 4


5 6 0 0


8 1 7 3 6 2 8 9 7 5


7 4 7 8 7 6 0 0


3 8 6 8 6 4


5 3 5 6 5 2 0 0


-1 -1


Sample Output:


Case 1 is a tree.


Case 2 is a tree.


Case 3 is not a tree.


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
#define N 100001
int f[N];
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    f[v]=getf(f[v]);
    return f[v];
  }
}
int main()
{
  int a,b,k=1;
  while(~scanf("%d %d",&a,&b)&&(a!=-1||b!=-1))
  {
    int flag=0;
    if(a==0&&b==0)//此情况为空树 
    {
      printf("Case %d is a tree.\n",k++);
      continue;
    }
    for(int i=1;i<=N;i++)
      f[i]=i;
    map<int,int> v;//记录出现过的端点 
    v[a]=v[b]=1;
    f[b]=a;
    if(a==b)//两个端点相同就不是 
      flag=1;
    while(scanf("%d %d",&a,&b))
    {
      if(a==0&&b==0)
        break;
      v[a]=v[b]=1;
      int t1=getf(a);
      int t2=getf(b);
      if(t1!=t2&&a!=b)
        f[t2]=t1;
      else
        flag=1;
    }
    if(flag)
      printf("Case %d is not a tree.\n",k++);
    else
    {
      map<int,int>::iterator it;
      for(it=v.begin();it!=v.end();it++)
      {//循环去遍历每一个端点,判断是不是只有一个祖宗 
        if(f[it->first]==(it->first))
          flag++;
      }
      if(flag==1)
        printf("Case %d is a tree.\n",k++);
      else
        printf("Case %d is not a tree.\n",k++);
    }
  }
  return 0;
}

 


相关文章
|
6月前
|
Java
POJ- 2367- Genealogical tree【拓扑排序】
POJ- 2367- Genealogical tree【拓扑排序】
22 0
|
存储 C++
剑指offer(C++)-JZ34:二叉树中和为某一值的路径(二)(数据结构-树)
剑指offer(C++)-JZ34:二叉树中和为某一值的路径(二)(数据结构-树)
剑指offer(C++)-JZ34:二叉树中和为某一值的路径(二)(数据结构-树)
剑指offer(C++)-JZ26:树的子结构(数据结构-树)
剑指offer(C++)-JZ26:树的子结构(数据结构-树)
|
算法 C++
剑指offer(C++)-JZ86:在二叉树中找到两个节点的最近公共祖先(数据结构-树)
剑指offer(C++)-JZ86:在二叉树中找到两个节点的最近公共祖先(数据结构-树)
剑指offer(C++)-JZ82:二叉树中和为某一值的路径(一)(数据结构-树)
剑指offer(C++)-JZ82:二叉树中和为某一值的路径(一)(数据结构-树)
|
存储 算法 C++
剑指offer(C++)-JZ84:二叉树中和为某一值的路径(三)(数据结构-树)
剑指offer(C++)-JZ84:二叉树中和为某一值的路径(三)(数据结构-树)
|
存储 算法 C语言
【树】你真的会二叉树了嘛? --二叉树LeetCode专题Ⅱ
这里有两种方法(深度优先搜索与广度优先搜索)其实也就是前序遍历与层序遍历,层序遍历这里简单提一下.与上面的大同小异就不过多赘述了:依旧是遍历出每一层最大的值,将其放入数组即可.
68 0
剑指offer_二叉树---树的子结构
剑指offer_二叉树---树的子结构
61 0
|
算法 前端开发 程序员
「LeetCode」617-合并二叉树⚡️
「LeetCode」617-合并二叉树⚡️
138 0
「LeetCode」617-合并二叉树⚡️
|
机器学习/深度学习 算法 前端开发
「LeetCode」100-相同的树⚡️
「LeetCode」100-相同的树⚡️
92 0
「LeetCode」100-相同的树⚡️