《Android传感器开发与智能设备案例实战》——第2章,第2.1节安装Android SDK的系统要求-阿里云开发者社区

开发者社区> 开发与运维> 正文

《Android传感器开发与智能设备案例实战》——第2章,第2.1节安装Android SDK的系统要求

简介:

本节书摘来自异步社区《Android传感器开发与智能设备案例实战》一书中的第2章,第2.1节安装Android SDK的系统要求,作者 朱元波,更多章节内容可以访问云栖社区“异步社区”公众号查看

第2章 搭建Android应用开发环境
Android传感器开发与智能设备案例实战
“工欲善其事,必先利其器”出自《论语》,意思是要想高效地完成一件事,需要有一个合适的工具。对于安卓开发人员来说,开发工具同样至关重要。作为一项新兴技术,在进行开发前首先要搭建一个对应的开发环境。而在搭建开发环境前,需要了解安装开发工具所需要的硬件和软件配置条件。Android开发包括底层开发和应用开发,底层开发大多数是指和硬件相关的开发,并且是基于Linux环境的,例如开发驱动程序。应用开发是指开发能在Android系统上运行的程序,例如游戏、地图等程序。本书的重点是讲解多媒体应用开发,即使讲一些底层的知识,也是为上层的应用服务的。因为开发Android智能设备程序既需要底层开发知识,也需要上层应用开发的知识。所以在本书需要讲解底层和应用开发环境的搭建知识。本章将首先介绍在Windows下搭建Android应用开发环境的过程。

2.1 安装Android SDK的系统要求
在搭建之前,一定先确定基于Android应用软件所需要开发环境的要求,具体如表2-1所示。

表2-1 开发系统所需求参数


48612104085d47d608ab20e1bc23f00658246f78

Android工具是由多个开发包组成的,具体说明如下。

JDK:可以到网址http://java.sun.com/javase/downloads/index.jsp处下载。
Eclipse(Europa):可以到网址http://www.eclipse.org/downloads/下载Eclipse IDE for Java Developers。
Android SDK:可以到网址http://developer.android.com下载。
还有对应的开发插件。

版权声明:本文首发在云栖社区,遵循云栖社区版权声明:本文内容由互联网用户自发贡献,版权归用户作者所有,云栖社区不为本文内容承担相关法律责任。云栖社区已升级为阿里云开发者社区。如果您发现本文中有涉嫌抄袭的内容,欢迎发送邮件至:developer2020@service.aliyun.com 进行举报,并提供相关证据,一经查实,阿里云开发者社区将协助删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章