HDOJ/HDU 1200 To and Fro(加密解密字符串)

本文涉及的产品
密钥管理服务KMS,1000个密钥,100个凭据,1个月
简介: HDOJ/HDU 1200 To and Fro(加密解密字符串)

Problem Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down


t o i o y

h p k n n

e l e a i

r a h s g

e c o n h

s e m o t

n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.


Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as


toioynnkpheleaigshareconhtomesnlewx


Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.


Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2… 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.


Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.


Sample Input

5

toioynnkpheleaigshareconhtomesnlewx

3

ttyohhieneesiaabss

0


Sample Output

theresnoplacelikehomeonasnowynightx

thisistheeasyoneab


水题。

译码还原问题


题目保证输入的数据一定是一个矩形的。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n=sc.nextInt();
            if(n==0){
                return;
            }
            String str=sc.next();
            String s[] = new String[str.length()/n];
            for(int i=0;i<str.length()/n;i++){
                s[i]="";//不要忘记初始化
                if(i%2==0){
                    for(int k=i*n;k<n+n*i;k++){
                        s[i]=s[i]+str.charAt(k);
                    }
                }else{
                    for(int k=i*n;k<n+n*i;k++){
                        s[i]=str.charAt(k)+s[i];
                    }
                }
                //System.out.println(s[i]);
            }
            for(int i=0;i<n;i++){
                for(int k=0;k<s.length;k++){
                    System.out.print(s[k].charAt(i));
                }
            }
            System.out.println();
        }
    }
}
目录
相关文章
|
4月前
|
数据安全/隐私保护
使用加密工具类进行有效的字符串加密——CSDN博客
使用加密工具类进行有效的字符串加密——CSDN博客
|
4月前
|
数据安全/隐私保护
常用的字符串加密解密工具类
常用的字符串加密解密工具类
|
23天前
|
存储 算法 数据库
使用python hashlib模块给明文字符串加密,以及如何撞库破解密码
`hashlib` 是 Python 中用于实现哈希功能的模块,它可以将任意长度的输入通过哈希算法转换为固定长度的输出,即散列值。该模块主要用于字符串加密,例如将用户名和密码转换为不可逆的散列值存储,从而提高安全性。`hashlib` 提供了多种哈希算法,如 `md5`、`sha1`、`sha256` 等。
35 1
|
3月前
|
存储 算法 Cloud Native
C++ bcrypt算法 字符串加密,亲测有效
C++ bcrypt算法 字符串加密,亲测有效
|
4月前
|
编解码 测试技术 数据安全/隐私保护
小工具实战-Python实现小工具输出字符串大小写转换、字符串统计、编解码、MD5加密
小工具实战-Python实现小工具输出字符串大小写转换、字符串统计、编解码、MD5加密
79 2
|
4月前
|
Java 数据安全/隐私保护
6-4 字符串加密(Java解法,两种网上的类型题)
6-4 字符串加密(Java解法,两种网上的类型题)
43 0
|
11月前
|
人工智能 数据安全/隐私保护
华为机试HJ36:字符串加密
华为机试HJ36:字符串加密
103 0
|
数据安全/隐私保护
[虚幻引擎] UE DTBase64 插件说明 使用蓝图对字符串,字节数组或文件进行Base64加密解密
本插件可以在虚幻引擎中使用蓝图对字符串,字节数组,文件进行Base64的加密和解密。
148 0
|
PHP 数据安全/隐私保护
PHP函数学习:16进制ASCII转化为字符串加密解密
PHP函数学习:16进制ASCII转化为字符串加密解密
254 0
|
数据安全/隐私保护
使用加密工具类进行有效的字符串加密——CSDN博客
使用加密工具类进行有效的字符串加密——CSDN博客