HDOJ/HDU 1087 Super Jumping! Jumping! Jumping!(经典DP~)

简介: HDOJ/HDU 1087 Super Jumping! Jumping! Jumping!(经典DP~)

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.




The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.


Input

Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.


Output

For each case, print the maximum according to rules, and one line one case.


Sample Input

3 1 3 2

4 1 2 3 4

4 3 3 2 1

0


Sample Output

4

10

3


就是找最大的递增子序列!!!


用动态规划做~


从前往后依次计算出当前递增子序列的值~dp[i]


最后找出最大的dp[i]就是答案~~

import java.util.Scanner;
/**
 * @author 陈浩翔
 *
 * 2016-5-26
 */
public class Main{
    public static void main(String[] args) {
        Scanner sc =new Scanner(System.in);
        while(sc.hasNext()){
            int n=sc.nextInt();
            if(n==0){
                break;
            }
            int a[]=new int[n];
            int dp[]=new int[n];
            for(int i=0;i<n;i++){
                a[i]=sc.nextInt();
            }
            dp[0]=a[0];
            for(int i=1;i<n;i++){
                int max=0;
                for(int j=0;j<i;j++){
                    if(a[j]<a[i]&&dp[j]>max){
                        max=dp[j];
                    }
                }
                dp[i]=a[i]+max;
            }
            int max=dp[0];
            for(int i=1;i<n;i++){
                if(dp[i]>max){
                    max=dp[i];
                }
            }
            System.out.println(max);
        }
    }
}
目录
相关文章
|
算法
Leetcode 313. Super Ugly Number
题目翻译成中文是『超级丑数』,啥叫丑数?丑数就是素因子只有2,3,5的数,7 14 21不是丑数,因为他们都有7这个素数。 这里的超级丑数只是对丑数的一个扩展,超级丑数的素因子不再仅限于2 3 5,而是由题目给定一个素数数组。与朴素丑数算法相比,只是将素因子变了而已,解法还是和朴素丑数一致的。
121 1
|
10月前
Strange fuction(HDU--2899)
Strange fuction(HDU--2899)
UVa355 - The Bases Are Loaded
UVa355 - The Bases Are Loaded
58 0
|
机器学习/深度学习
1257:Knight Moves 2021-01-09
1257:Knight Moves 2021-01-09
|
存储
LeetCode 313. Super Ugly Number
编写一段程序来查找第 n 个超级丑数。 超级丑数是指其所有质因数都是长度为 k 的质数列表 primes 中的正整数。
118 0
LeetCode 313. Super Ugly Number
AtCoder Beginner Contest 214 F - Substrings(subsequence DP)
AtCoder Beginner Contest 214 F - Substrings(subsequence DP)
110 0
|
Perl
AtCoder Beginner Contest 217 F - Make Pair (区间dp)
AtCoder Beginner Contest 217 F - Make Pair (区间dp)
140 0
|
人工智能
Educational Codeforces Round 98 (Rated for Div. 2)B-Toy Blocks
You are asked to watch your nephew who likes to play with toy blocks in a strange way. He has n boxes and the i-th box has ai blocks. His game consists of two steps: he chooses an arbitrary box i; he tries to move all blocks from the i-th box to other boxes.
277 0
HDOJ(HDU) 2317 Nasty Hacks(比较、)
HDOJ(HDU) 2317 Nasty Hacks(比较、)
115 0