HDOJ/HDU 1062 Text Reverse(字符串翻转~)

简介: HDOJ/HDU 1062 Text Reverse(字符串翻转~)

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.


Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.


Output

For each test case, you should output the text which is processed.


Sample Input

3

olleh !dlrow

m’I morf .udh

I ekil .mca


Sample Output

hello world!

I’m from hdu.

I like acm.


Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.


题意:

输入一行字符串,将每一个单词(只有空格隔开)倒序输出!


注意:

开始和结尾可能有多个空格,单词之间可能有多个空格!


PE的请注意:空格必须照原样输出!有几个输出几个,不能多输出也不能少输出!

import java.util.Scanner;
/**
 * @author 陈浩翔
 * 2016-5-25
 */
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        sc.nextLine();//读取输入t之后的回车
        while(t-->0){
            String str=sc.nextLine();
            String s[] = str.split(" ");
            String str2="";
            for(int i=0;i<s.length;i++){
                for(int k=s[i].length()-1;k>=0;k--){
                    System.out.print(s[i].charAt(k));
                    str2+=s[i].charAt(k);
                }
                if(i!=s.length-1){
                    System.out.print(" ");
                    str2+=" ";
                }
            }
            for(int i=str2.length();i<str.length();i++){
                System.out.print(" ");
            }
            System.out.println();
        }
    }
}
目录
相关文章
|
6月前
|
机器学习/深度学习
hdu 1061 Rightmost Digit
hdu 1061 Rightmost Digit
17 0
Leetcode-Easy 412. Fizz Buzz
Leetcode-Easy 412. Fizz Buzz
67 0
Leetcode-Easy 412. Fizz Buzz
|
存储
HDOJ/HDU 1073 Online Judge(字符串处理~)
HDOJ/HDU 1073 Online Judge(字符串处理~)
78 0
|
机器学习/深度学习 人工智能 BI
HDOJ/HDU 2550 百步穿杨(注意排序)
HDOJ/HDU 2550 百步穿杨(注意排序)
87 0
HDOJ(HDU) 1491 Octorber 21st
HDOJ(HDU) 1491 Octorber 21st
102 0
HDOJ(HDU) 1491 Octorber 21st
HDOJ(HDU) 4847 Wow! Such Doge!(doge字符统计)
HDOJ(HDU) 4847 Wow! Such Doge!(doge字符统计)
106 0
HDOJ(HDU) 2061 Treasure the new start, freshmen!(水题、)
HDOJ(HDU) 2061 Treasure the new start, freshmen!(水题、)
109 0
HDOJ/HDU 1984 Mispelling4(删除第n个字符~)
HDOJ/HDU 1984 Mispelling4(删除第n个字符~)
81 0
HDOJ/HDU 1015 Safecracker(枚举)
HDOJ/HDU 1015 Safecracker(枚举)
87 0
HDOJ/HDU 2535 Vote(排序、)
HDOJ/HDU 2535 Vote(排序、)
83 0