HDOJ/HDU 1062 Text Reverse(字符串翻转~)

简介: HDOJ/HDU 1062 Text Reverse(字符串翻转~)

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.


Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.


Output

For each test case, you should output the text which is processed.


Sample Input

3

olleh !dlrow

m’I morf .udh

I ekil .mca


Sample Output

hello world!

I’m from hdu.

I like acm.


Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.


题意:

输入一行字符串,将每一个单词(只有空格隔开)倒序输出!


注意:

开始和结尾可能有多个空格,单词之间可能有多个空格!


PE的请注意:空格必须照原样输出!有几个输出几个,不能多输出也不能少输出!

import java.util.Scanner;
/**
 * @author 陈浩翔
 * 2016-5-25
 */
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        sc.nextLine();//读取输入t之后的回车
        while(t-->0){
            String str=sc.nextLine();
            String s[] = str.split(" ");
            String str2="";
            for(int i=0;i<s.length;i++){
                for(int k=s[i].length()-1;k>=0;k--){
                    System.out.print(s[i].charAt(k));
                    str2+=s[i].charAt(k);
                }
                if(i!=s.length-1){
                    System.out.print(" ");
                    str2+=" ";
                }
            }
            for(int i=str2.length();i<str.length();i++){
                System.out.print(" ");
            }
            System.out.println();
        }
    }
}
目录
相关文章
|
7月前
|
机器学习/深度学习 安全 Java
hdu-1596-find the safest road(dijkstra)
hdu-1596-find the safest road(dijkstra)
46 0
|
机器学习/深度学习
HDOJ 1061 Rightmost Digit(循环问题)
HDOJ 1061 Rightmost Digit(循环问题)
120 0
HDOJ 1061 Rightmost Digit(循环问题)
HDOJ/HDU 1321 Reverse Text(倒序输出~)
HDOJ/HDU 1321 Reverse Text(倒序输出~)
103 0
HDOJ(HDU) 2115 I Love This Game(排序排序、、、)
HDOJ(HDU) 2115 I Love This Game(排序排序、、、)
96 0
|
Java
HDOJ/HDU 2087 剪花布条(indexOf()应用~~)
HDOJ/HDU 2087 剪花布条(indexOf()应用~~)
124 0
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
141 0
|
Java
HDOJ/HDU 1297 Children’s Queue(推导~大数)
HDOJ/HDU 1297 Children’s Queue(推导~大数)
143 0
|
存储
HDOJ/HDU 1073 Online Judge(字符串处理~)
HDOJ/HDU 1073 Online Judge(字符串处理~)
103 0
|
搜索推荐
HDOJ/HDU 1251 统计难题(字典树啥的~Map水过)
HDOJ/HDU 1251 统计难题(字典树啥的~Map水过)
87 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
241 0