HDOJ(HDU) 1673 Optimal Parking

简介: HDOJ(HDU) 1673 Optimal Parking

Problem Description

When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.

Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?

Long Street is a straight line, where all positions are integer.

You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.


Input

The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.


Output

Output for each test case a line with the minimal distance Michael must walk given optimal parking.


Sample Input

2

4

24 13 89 37

6

7 30 41 14 39 42


Sample Output

152

70


真心的题意难懂啊。。懂了之后就是大水题,大水题、、、


题意:一条路上有n家商店,给出坐标。某人停车在某点后,要逛完所有商店回到车出。停车地点自选,求最少需要步行多远。


无论停在那个商店,总要回来的,也就是说一定会是从最小坐标到最大坐标的距离的两倍!!!

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc  = new Scanner(System.in);
        int t =sc.nextInt();
        while(t-->0){
            int n = sc.nextInt();
            int min=sc.nextInt();
            int max = min;
            int m;
            while(n-->1){
                m = sc.nextInt();
                if(m>max){
                    max=m;
                }
                if(m<min){
                    min=m;
                }
            }
            System.out.println(2*(max-min));
        }
    }
}
目录
相关文章
hdoj 4572 Bottles Arrangement
虽然不知道怎么做,但是AC还是没有问题的。 大概就是循环n次,从m加到m-n/2 除了最后一个数,每个都加两次。
42 0
hdoj 2089 不要62
这题数据量相对比较小,可以暴力打表解决。不过我这里用数位dp 刚开始学数位dp,参考了别人的代码。
58 0
|
算法
HDOJ 3466 Proud Merchants
HDOJ 3466 Proud Merchants
108 0
HDOJ 3466 Proud Merchants
|
机器学习/深度学习
HDOJ 2074 叠筐
HDOJ 2074 叠筐
123 0
HDOJ 2041 超级楼梯
HDOJ 2041 超级楼梯
108 0
|
安全
HDOJ 2022 海选女主角
HDOJ 2022 海选女主角
155 0
HDOJ 1412 {A} + {B}
Problem Description 给你两个集合,要求{A} + {B}. 注:同一个集合中不会有两个相同的元素. Input 每组输入数据分为三行,第一行有两个数字n,m(0 < n,m marr[mid]) { System.
781 0
HDOJ 2057 A + B Again
Problem Description There must be many A + B problems in our HDOJ , now a new one is coming.
904 0