HDOJ 1420 Prepared for New Acmer(DP)

简介: HDOJ 1420 Prepared for New Acmer(DP)

Problem Description

集训进行了将近2个礼拜,这段时间以恢复性训练为主,我一直在密切关注大家的训练情况,目前为止,对大家的表现相当满意,首先是绝大部分队员的训练积极性很高,其次,都很遵守集训纪律,最后,老队员也起到了很好的带头作用,这里特别感谢为这次DP专题练习赛提供题目和测试数据的集训队队长xhd同学.


特别高兴的是,跟随集训队训练的一批新队员表现非常好,进步也比较显著,特别是训练态度大大超出我的预期,我敢说,如果各位能如此坚持下去,绝对前途无量!


考虑到新队员还没有经过系统训练,我这里特别添加一道简单题:

给定三个正整数A,B和C(A,B,C<=1000000),求A^B mod C的结果.


希望各位都能体会到比赛中AC的快乐,绝对的量身定制,很高的待遇哟,呵呵…


Input

输入数据首先包含一个正整数N,表示测试实例的个数,然后是N行数据,每行包括三个正整数A,B,C。


Output

对每个测试实例请输出计算后的结果,每个实例的输出占一行。


Sample Input

3

2 3 4

3 3 5

4 4 6


Sample Output

0

2

4


开始想直接用java大数A过的,单发现取余不会超范围。

事实证明取余循环是可以AC的。

至于用java的大数过,就你们自己去试下吧,我觉得应该是可以过的。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            long a = sc.nextLong();
            long b = sc.nextLong();
            long c = sc.nextLong();
            long num = a;
            for(int i=1;i<b;i++){
                a=a%c;
                //System.out.println("1  "+a);
                a=a*num;
                //System.out.println("2  "+a);
            }
            System.out.println(a%c);
        }
    }
}
目录
相关文章
|
7月前
|
前端开发 JavaScript 测试技术
【PTA】L1-32 Left-pad (C++)
【PTA】L1-32 Left-pad (C++)
45 0
【PTA】L1-32 Left-pad (C++)
hdoj 1028/poj 2704 Pascal's Travels(记忆化搜索||dp)
有个小球,只能向右边或下边滚动,而且它下一步滚动的步数是它在当前点上的数字,如果是0表示进入一个死胡同。求它从左上角到右下角到路径数目。 注意, 题目给了提示了,要用64位的整数。
37 0
light oj 1231-1232 - 1233- Coin Change 背包
暂时到半懂不懂也没办法讲明白,就不误人子弟了,直接贴代码了。
35 0
HDU - 1312 Red and Black(DFS)
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles. Write a program to count the number of black
87 0
|
C++
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
99 0
|
机器学习/深度学习 存储 C++
【PAT甲级 - C++题解】1053 Path of Equal Weight
【PAT甲级 - C++题解】1053 Path of Equal Weight
83 0
|
机器学习/深度学习 Windows
Codeforces Round #748 (Div. 3) F - Red-Black Number (记忆化搜索)
Codeforces Round #748 (Div. 3) F - Red-Black Number (记忆化搜索)
101 0
AtCoder Beginner Contest 222 E - Red and Blue Tree(dfs dp)
AtCoder Beginner Contest 222 E - Red and Blue Tree(dfs dp)
116 0