HDOJ 1196 Lowest Bit(二进制相关的简单题)

简介: HDOJ 1196 Lowest Bit(二进制相关的简单题)

Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.


For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.


Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.


Output

For each A in the input, output a line containing only its lowest bit.


Sample Input

26

88

0


Sample Output

2

8


输入一个十进制的数:然后转换为二进制,输出二进制的位数从后面到前面数的第一个1的时候的数的十进制。

例如:26二进制是11010,所以从后面对前面数,第二位为1,所以取值为10,再转换成十进制,输出为2;

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n==0){
                return ;
            }
            String str = Integer.toString(n, 2);
            //System.out.println(str);
            for(int i=str.length()-1;i>=0;i--){
                if(str.charAt(i)=='1'){
                    System.out.println((int)Math.pow(2, str.length()-1-i));
                    break;
                }
            }
        }
    }
}
目录
相关文章
|
8月前
|
存储 网络协议 C语言
一文带你秒懂 字节序(byte order),比特序(bit order),位域(bit field)
一文带你秒懂 字节序(byte order),比特序(bit order),位域(bit field)
1026 0
hdu 1196 Lowest Bit(水题)
hdu 1196 Lowest Bit(水题)
47 0
|
存储 算法 测试技术
UVA240 Variable Radix Huffman Encoding
UVA240 Variable Radix Huffman Encoding
UVA240 Variable Radix Huffman Encoding
|
Java
HDOJ 1018 Big Number(大数位数公式)
HDOJ 1018 Big Number(大数位数公式)
117 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
242 0
|
前端开发
HDOJ 1212 Big Number
HDOJ 1212 Big Number
115 0
HDOJ(HDU) 2106 decimal system(进制相互转换问题)
HDOJ(HDU) 2106 decimal system(进制相互转换问题)
94 0
HDOJ1018Big Number
HDOJ1018Big Number
112 0
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
133 0