HDOJ 1196 Lowest Bit(二进制相关的简单题)

简介: HDOJ 1196 Lowest Bit(二进制相关的简单题)

Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.


For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.


Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.


Output

For each A in the input, output a line containing only its lowest bit.


Sample Input

26

88

0


Sample Output

2

8


输入一个十进制的数:然后转换为二进制,输出二进制的位数从后面到前面数的第一个1的时候的数的十进制。

例如:26二进制是11010,所以从后面对前面数,第二位为1,所以取值为10,再转换成十进制,输出为2;

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n==0){
                return ;
            }
            String str = Integer.toString(n, 2);
            //System.out.println(str);
            for(int i=str.length()-1;i>=0;i--){
                if(str.charAt(i)=='1'){
                    System.out.println((int)Math.pow(2, str.length()-1-i));
                    break;
                }
            }
        }
    }
}
目录
相关文章
|
9月前
codeforces 339 D.Xenia and Bit Operations(线段树)
输入n,m表示有2^n个数和m个更新,每次更新只把p位置的值改成b,然后输出整个序列运算后的值,而这个运算就比较复杂了, 最下面一层两个数字之间或运算得到原来数目一半的数字,然后两个之间异或运算,得到一半,再或再异或………………,一直到得到一个数字,这个数字就是要求的结果。
32 0
|
索引
Leetcode-Medium 6. ZigZag Conversion
Leetcode-Medium 6. ZigZag Conversion
75 0
Leetcode-Medium 6. ZigZag Conversion
|
Java
HDOJ 1018 Big Number(大数位数公式)
HDOJ 1018 Big Number(大数位数公式)
91 0
|
前端开发
HDOJ 1212 Big Number
HDOJ 1212 Big Number
92 0
|
Java
HDOJ(HDU) 1720 A+B Coming(进制)
HDOJ(HDU) 1720 A+B Coming(进制)
95 0
HDOJ1018Big Number
HDOJ1018Big Number
94 0
HDOJ(HDU) 2106 decimal system(进制相互转换问题)
HDOJ(HDU) 2106 decimal system(进制相互转换问题)
76 0
HDOJ 1335 Basically Speaking(进制转换)
HDOJ 1335 Basically Speaking(进制转换)
79 0
|
机器学习/深度学习
POJ 1423 Big Number
POJ 1423 Big Number
86 0
LeetCode---Problem6 ZigZag Conversion
ZigZag问题思路。代码整洁并不一定执行速度就好~
772 0