HDOJ 1076 An Easy Task(闰年计算)

简介: HDOJ 1076 An Easy Task(闰年计算)

Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?


Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.


Note: if year Y is a leap year, then the 1st leap year is year Y.


Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains two positive integers Y and N(1<=N<=10000).


Output

For each test case, you should output the Nth leap year from year Y.


Sample Input

3

2005 25

1855 12

2004 10000


Sample Output

2108

1904

43236


Hint:

We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.


题意就是:输入一个年份year和一个n,求这个year之后的第n个闰年,

如果year是闰年,则算第一个闰年。


直接暴力做,并没有超时。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int year = sc.nextInt();
            int n = sc.nextInt();
            int nyear = 0;
            if((year%4==0&&year%100!=0)|(year%400==0)){
                nyear=1;
            }//如果year是闰年,nyear就加一
            while(nyear<n){//当nyear小于n时,就循环
                year++;
                if((year%4==0&&year%100!=0)|(year%400==0)){
                    nyear++;
                }//year是闰年,nyear就加加
            }
            System.out.println(year);
        }
    }
}
目录
相关文章
|
C++
hdoj 4288coder & cf 85d Sum of Medians
这两个题目是一样的,大概题意是有3个操作 add x, 在集合中加入x, del x 是删除x, sum 是求出由小到大排序后所有下标mod5等于3的数的和。
33 0
初学算法之---pta fun with numbers
初学算法之---pta fun with numbers
Leetcode-Easy 437. Path Sum III
Leetcode-Easy 437. Path Sum III
91 0
Leetcode-Easy 437. Path Sum III
Leetcode-Easy 709. To Lower Case
Leetcode-Easy 709. To Lower Case
106 0
Leetcode-Easy 709. To Lower Case
HDOJ 1339 A Simple Task(简单数学题,暴力)
HDOJ 1339 A Simple Task(简单数学题,暴力)
113 0
HDOJ(HDU) 2162 Add ‘em(求和)
HDOJ(HDU) 2162 Add ‘em(求和)
73 0
HDOJ 1019 Least Common Multiple(最小公倍数问题)
HDOJ 1019 Least Common Multiple(最小公倍数问题)
95 0
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
127 0
|
Java C语言
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
98 0