HDOJ 1076 An Easy Task(闰年计算)

简介: HDOJ 1076 An Easy Task(闰年计算)

Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?


Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.


Note: if year Y is a leap year, then the 1st leap year is year Y.


Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains two positive integers Y and N(1<=N<=10000).


Output

For each test case, you should output the Nth leap year from year Y.


Sample Input

3

2005 25

1855 12

2004 10000


Sample Output

2108

1904

43236


Hint:

We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.


题意就是:输入一个年份year和一个n,求这个year之后的第n个闰年,

如果year是闰年,则算第一个闰年。


直接暴力做,并没有超时。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int year = sc.nextInt();
            int n = sc.nextInt();
            int nyear = 0;
            if((year%4==0&&year%100!=0)|(year%400==0)){
                nyear=1;
            }//如果year是闰年,nyear就加一
            while(nyear<n){//当nyear小于n时,就循环
                year++;
                if((year%4==0&&year%100!=0)|(year%400==0)){
                    nyear++;
                }//year是闰年,nyear就加加
            }
            System.out.println(year);
        }
    }
}
目录
相关文章
|
8月前
|
测试技术 C++
【PTA】​L1-003 个位数统计​ (C++)
【PTA】​L1-003 个位数统计​ (C++)
159 0
【PTA】​L1-003 个位数统计​ (C++)
|
C++
hdoj 4288coder & cf 85d Sum of Medians
这两个题目是一样的,大概题意是有3个操作 add x, 在集合中加入x, del x 是删除x, sum 是求出由小到大排序后所有下标mod5等于3的数的和。
37 0
复习C部分://1.练习:打印1000~2000的闰年 //2.写一个代码,打印100~200之间的素数 3.goto 跳去哪里
复习C部分://1.练习:打印1000~2000的闰年 //2.写一个代码,打印100~200之间的素数 3.goto 跳去哪里
93 0
复习C部分://1.练习:打印1000~2000的闰年 //2.写一个代码,打印100~200之间的素数 3.goto 跳去哪里
Leetcode-Easy 437. Path Sum III
Leetcode-Easy 437. Path Sum III
101 0
Leetcode-Easy 437. Path Sum III
|
Python
Python编程:dateutil模块实现月份相加减
Python编程:dateutil模块实现月份相加减
163 0
【1081】Rational Sum (20 分)
【1081】Rational Sum (20 分) 【1081】Rational Sum (20 分)
103 0
【1075】PAT Judge (25 分)
【1075】PAT Judge (25 分) 【1075】PAT Judge (25 分)
120 0
【1011】World Cup Betting (20 分)
【1011】World Cup Betting (20 分) 【1011】World Cup Betting (20 分)
100 0