HDOJ 1033 Edge

简介: HDOJ 1033 Edge

Problem Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.


Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.


Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command “300 420 moveto”. The first turn occurs at (310, 420) using the command “310 420 lineto”. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of “x y lineto” commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.


You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.


image.png


Sample Input

V

AVV


Sample Output

300 420 moveto

310 420 lineto

310 430 lineto

stroke

showpage

300 420 moveto

310 420 lineto

310 410 lineto

320 410 lineto

320 420 lineto

stroke

showpage


问题描述:

对于放入小的包裹的产品来说,将使用说明(sheet)折叠到合适大小是很有必要的。我们假定sheet是矩形的,并且只沿着平行于新形成的较短的边的线进行折叠。但是沿着这条线折叠的做法,有两个方向可以完成:可以是sheet的上表面折叠到一起,或者是sheet的下表面折叠到一起。这两种方式中,被折痕分割的矩形的两部分会恰好铺放在一起。我们忽略纸张的厚度。等完成几步折叠后,我们可以打开sheet查看形成的长边(即折痕),结果呈现出的实际上是一系列连续的线段,我们也按一定的方向沿着曲线(折痕连起来的折线)可以把每处折痕分为顺时针(用A表示)、逆时针(用V表示)两类。根据给定的这样分类的序列,画出sheet的长边(折痕)的图像,假设在等距离的地方折角为90°。


输入:

输入包含几例测试数据,每例测试数据单独占一行。每行包含不为空的描述sheet的长边的字符A和V组成的字符串。你可以假定字符串少于200个字符。最后一例测试完成后立即结束


输出:

每例产生一个PostScript,绘画edge的命令行占单独一行。每例绘画使用命令”300 420 moveto”在点(300,420)开始 ,第一个转折使用命令”310 420 lineto”发生在折点(310, 420)。随后按照输入的字符串顺时针或逆时针的绘画,使用命令 “x y lineto”在合适的点。折点以10个单位划分。完成最后一点并且以命令”stroke”和”showpage”结束。


说了这么多,没什么卵用,其实就是理解A是向顺时针转,V是向逆时针。。。。初始坐标是300,420,每次走10。。。。。。找好初始的1的位置,模拟就可以了,四个走向。

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            String str = sc.nextLine();
            int x=310,y=420;
            System.out.println(300+" "+420+" "+"moveto");
            System.out.println(310+" "+420+" "+"lineto");
            int fx = 1;
            for(int i=0;i<str.length();i++){
                if(str.charAt(i)=='A'){
                    if(fx==1){
                        y-=10;
                        fx=2;
                    }else if(fx==2){
                        x-=10;
                        fx=3;
                    }else if(fx==3){
                        y+=10;
                        fx=4;
                    }else if(fx==4){
                        x+=10;
                        fx=1;
                    }
                    System.out.println(x+" "+y+" lineto");
                }else{
                    if(fx==1){
                        y+=10;
                        fx=4;
                    }else if(fx==2){
                        x+=10;
                        fx=1;
                    }else if(fx==3){
                        y-=10;
                        fx=2;
                    }else if(fx==4){
                        x-=10;
                        fx=3;
                    }
                    System.out.println(x+" "+y+" lineto");
                }
            }
            System.out.println("stroke");
            System.out.println("showpage");
        }
    }
}
目录
相关文章
|
5月前
|
开发者
查看edge浏览器插件的安装位置并将插件安装到别的浏览器
查看edge浏览器插件的安装位置并将插件安装到别的浏览器
202 1
|
5月前
|
文字识别 安全 JavaScript
6款超实用的Edge浏览器插件,让你的浏览器瞬间开挂!
Microsoft Edge是由微软开发的一款网页浏览器,致力于提供一个现代化、高效率、安全可靠的网络浏览器,以满足用户对于网络浏览的各种需求。
276 1
|
5天前
|
安全 Oracle Java
edge浏览器加载java插件
edge浏览器加载java插件
28 1
|
7天前
|
安全
微软网站上关于在Edge浏览器中打开或关闭smartScreen的说明有误
微软网站上关于在Edge浏览器中打开或关闭smartScreen的说明有误
微软网站上关于在Edge浏览器中打开或关闭smartScreen的说明有误
|
1月前
|
Web App开发 缓存 安全
解决Edge浏览器提示“此网站已被人举报不安全”
【9月更文挑战第1天】当 Edge 浏览器提示“此网站被举报为不安全”时,可尝试:关闭 Microsoft Defender SmartScreen;检查网站安全性;清除缓存和 Cookie;更新 Edge 至最新版;或使用其他浏览器。若问题依旧,联系网站管理员和技术支持。同时,避免在不可信网站输入敏感信息,保护网络安全与隐私。
165 7
|
2月前
|
数据采集 Web App开发 测试技术
使用Selenium调试Edge浏览器的常见问题与解决方案
在互联网数据采集领域,Selenium常用于自动化网页爬取。针对使用Edge浏览器时遇到的启动远程调试失败、访问受限及代理IP设置等问题,本文提供了解决方案。通过特定命令启动Edge的远程调试模式,并利用Python脚本配合Selenium库,可实现代理IP、User-Agent的设定及Cookie管理等高级功能,有效提升爬虫稳定性和隐蔽性。遵循步骤配置后,即可顺畅执行自动化测试任务。
300 1
使用Selenium调试Edge浏览器的常见问题与解决方案
|
2月前
|
存储 缓存 安全
解决Edge浏览器提示“此网站已被人举报不安全”
【8月更文挑战第19天】如果Edge浏览器提示“此网站已被人举报不安全”,首先确认网站可信度及安全证书有效性,避免访问可疑网站。检查浏览器是否需要更新,并确保自动更新功能已开启。可暂时关闭Microsoft Defender SmartScreen(不建议长期关闭),清除缓存和Cookies,或检查第三方安全软件设置。若问题持续,考虑重置Edge浏览器设置,保留重要数据。如仍无法解决,联系网站管理员或微软支持。
206 7
|
2月前
Edge——如何打开IE浏览器进行访问
Edge——如何打开IE浏览器进行访问
46 4
|
2月前
|
Web App开发 编解码 监控
【Azure 媒体服务】Azure Media Player 在Edge浏览器中不能播放视频问题的分析与解决
【Azure 媒体服务】Azure Media Player 在Edge浏览器中不能播放视频问题的分析与解决
|
2月前
|
IDE 开发工具
Edge浏览器——如何设置跨域请求
Edge浏览器——如何设置跨域请求
105 0

热门文章

最新文章

下一篇
无影云桌面