HDOJ 2052 Picture

简介: HDOJ 2052 Picture

Problem Description

Give you the width and height of the rectangle,darw it.


Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.


Output

For each case,you should draw a rectangle with the width and height giving in the input.

after each case, you should a blank line.


Sample Input

3 2

Sample Output
+---+
|   |
|   |
+---+


别忘了每一个输出后面空一行

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int m = sc.nextInt();
            int n = sc.nextInt();
            for(int i=0;i<n+2;i++){
                for(int j=0;j<m+2;j++){
                    if(i==0){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else if(i==n+1){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else {
                        if(j==0||j==m+1){
                            System.out.print("|");
                        }else{
                            System.out.print(" ");
                        }
                    }
                }
                System.out.println();
            }
            System.out.println();
        }
    }
}
目录
相关文章
Bear and Big Brother
Bear and Big Brother
103 0
Bear and Big Brother
HDOJ(HDU) 2317 Nasty Hacks(比较、)
HDOJ(HDU) 2317 Nasty Hacks(比较、)
107 0
|
Java
HDOJ(HDU) 2164 Rock, Paper, or Scissors?
HDOJ(HDU) 2164 Rock, Paper, or Scissors?
118 0
HDOJ(HDU) 2103 Family planning(需要注意范围)
HDOJ(HDU) 2103 Family planning(需要注意范围)
105 0
|
机器学习/深度学习 并行计算 Java