HDOJ 2017 字符串统计

简介: HDOJ 2017 字符串统计

Problem Description

对于给定的一个字符串,统计其中数字字符出现的次数。


Input

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。


Output

对于每个测试实例,输出该串中数值的个数,每个输出占一行。


Sample Input

2

asdfasdf123123asdfasdf

asdf111111111asdfasdfasdf


Sample Output

6

9


需要注意的只有一个地方,就是输入数字后回车的处理。

import java.util.Scanner;
class Main{
    public static void main(String args[]){
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        String str1 = sc.nextLine();
        while(t-->0){
            String str = sc.nextLine();
            int lengnum = 0;
            for(int i=0;i<str.length();i++){
                char cstr = str.charAt(i);
                if(cstr>='0'&&cstr<='9'){
                    lengnum++;                  
                }               
            }
            System.out.println(lengnum);            
        }       
    }
}
目录
相关文章
leet_code_696.计数二进制子串(分组计数)
leet_code_696.计数二进制子串(分组计数)
66 0
LeetCode contest 200 5475. 统计好三元组 Count Good Triplets
LeetCode contest 200 5475. 统计好三元组 Count Good Triplets
HDOJ 2027 统计元音
HDOJ 2027 统计元音
106 0
HDOJ 2008 数值统计
HDOJ 2008 数值统计
84 0
HDOJ 2030 汉字统计
HDOJ 2030 汉字统计
107 0
|
测试技术
HDOJ(HDU) 1860 统计字符
HDOJ(HDU) 1860 统计字符
102 0
HDOJ 2072 单词数
HDOJ 2072 单词数
92 0
HDOJ 2000 ASCII码排序
HDOJ 2000 ASCII码排序
107 0
|
测试技术
HDOJ 1106 排序
HDOJ 1106 排序
104 0