POJ 1775 (ZOJ 2358) Sum of Factorials

简介: POJ 1775 (ZOJ 2358) Sum of Factorials

Description


John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics,meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest. His Ph.D. dissertation on set theory was an important contribution to the subject. At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundations of Quantum Mechanics (1932) built a solid framework for the new scientific discipline. During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944).

There are some numbers which can be expressed by the sum of factorials. For example 9,9=1!+2!+3! Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell him whether or not the number can be expressed by the sum of some factorials.

Well, it’s just a piece of cake. For a given n, you’ll check if there are some xi, and let n equal to Σ1<=i<=txi!. (t >=1 1, xi >= 0, xi = xj iff. i = j). If the answer is yes, say “YES”; otherwise, print out “NO”.

Input


You will get several non-negative integer n (n <= 1,000,000) from input file. Each one is in a line by itself.

The input is terminated by a line with a negative integer.

Output


For each n, you should print exactly one word (“YES” or “NO”) in a single line. No extra spaces are allowed.

Sample Input


9

-1

Sample Output


YES


注意:0的阶乘是1;(输入0,输出NO)

不是输入-1结束,而是输入负数结束程序;

题目要求不是连续阶乘和;

例如:4=0!+1!+2!=1+1+2

输出 YES;

7=3!+1!;

输出 YES;


我这里的思路是:

从不大于n的最大数开始减,如果能减到n为0,输出YES,否则

输出NO。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int a[10];
void df(){
   for(int i=1;i<10;i++){
     a[i]=i*a[i-1];
   }
}
int main()
{
    a[0]=1;
    df();
//    for(int i=0;i<10;i++){
//        printf("%d\n",a[i]);
//    }
    int n;
    int sum;
    while(scanf("%d",&n)==1&&n>=0){
            sum=n;
            if(n==0){
                printf("NO\n");
                continue;
            }
            int flag=0;
        for(int i=9;i>=0;i--){
            if(a[i]<=sum){
                sum=sum-a[i];
               // printf("i=%d,%d\n",i,a[i]);
            }
        if(sum==0){
            printf("YES\n");
            flag=1;
            break;
        }
        }
        if(flag==0)
        printf("NO\n");
    }
    return 0;
}
目录
相关文章
|
7月前
|
Java 测试技术
hdu 1228 A + B
hdu 1228 A + B
50 0
|
Java 测试技术
hdu 1228 A + B
hdu 1228 A + B
56 0
|
人工智能 Java
hdu 1712 ACboy needs your help
ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。
143 0
HDU2203亲和串
博客水平见水平......目前阶段就是这么菜,我会好好努力的!毕业直接拿到阿里offer!
1231 0
|
机器学习/深度学习 算法
|
Java 测试技术
HDU 1232 畅通工程
畅通工程 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 50540    Accepted Submission(s): 26968 Problem Description 某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。
1024 0