POJ 2487 Stamps

简介: POJ 2487 Stamps

Description


Background

Everybody hates Raymond. He’s the largest stamp collector on planet earth and because of that he always makes fun of all the others at the stamp collector parties. Fortunately everybody loves Lucy, and she has a plan. She secretly asks her friends whether they could lend her some stamps, so that she can embarrass Raymond by showing an even larger collection than his.

Problem

Raymond is so sure about his superiority that he always tells how many stamps he’ll show. And since Lucy knows how many she owns, she knows how many more she needs. She also knows how many friends would lend her some stamps and how many each would lend. But she’d like to borrow from as few friends as possible and if she needs too many then she’d rather not do it at all. Can you tell her the minimum number of friends she needs to borrow from?

Input


The first line contains the number of scenarios. Each scenario describes one collectors party and its first line tells you how many stamps (from 1 to 1000000) Lucy needs to borrow and how many friends (from 1 to 1000) offer her some stamps. In a second line you’ll get the number of stamps (from 1 to 10000) each of her friends is offering.

Output


The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the minimum number of friends Lucy needs to borrow stamps from. If it’s impossible even if she borrows everything from everybody, write impossible. Terminate the output for the scenario with a blank line.

Sample Input


3

100 6

13 17 42 9 23 57

99 6

13 17 42 9 23 57

1000 3

314 159 265

Sample Output


Scenario #1:

3


Scenario #2:

2


Scenario #3:

impossible

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int main(){
    int n;
    int Case=1;
    scanf("%d",&n);
    while(n--){
        int x,y;
        scanf("%d %d",&x,&y);
        int i;
        int arr[1010];
        for(i=0;i<y;i++){
            scanf("%d",&arr[i]);
        }
        sort(arr,arr+y);
        int sum=0;
        for(i=y-1;i>=0;i--){
            sum=sum+arr[i];
            if(sum>=x){
                    break;
            }
        }
        printf("Scenario #%d:\n",Case++);
        if(sum>=x)
            printf("%d\n",y-i);
        else
            printf("impossible\n");
        if(n)
            putchar(10);
    }
    return 0;
}
目录
相关文章
|
8月前
|
算法 数据建模
Poj 3169(差分约束系统)
Poj 3169(差分约束系统)
38 0
|
算法 数据建模 机器学习/深度学习
POJ 1067 取石子游戏
取石子游戏 Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 40917   Accepted: 13826 Description 有两堆石子,数量任意,可以不同。
1125 0
|
C语言
poj 2503 查字典
Description You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language.
877 0
|
人工智能 BI
poj-3185-开关问题
描述   牛一行20他们喝的水碗。碗可以那么(面向正确的为清凉水)或颠倒的(一个位置而没有水)。他们希望所有20个水碗那么,因此用宽鼻子翻碗。   嘴太宽,他们不仅翻转一碗还碗的碗两侧(总共三个或三个——在两端的情况下碗——两碗)。
818 0

热门文章

最新文章