HDU 1251

简介: 统计难题 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others) Total Submission(s): 10040    Accepted Submission(s): 4074 Problem Description Ignatius最近遇到一个难题,老师

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 10040    Accepted Submission(s): 4074


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
 
 
banana band bee absolute acm ba b band abc
 

Sample Output
 
 
2 3 1 0
#include "stdio.h"
#include "string.h"
#include "stdlib.h"
struct dictree
{
    struct dictree *child[26];
    int n;
};
struct dictree *root;

void insert (char *source)
{
    int len,i,j;
    struct dictree *current,*newnode;
    len=strlen(source);
    if(len==0) return;
    current= root;
    for(i=0;i<len;i++)
    {
        if(current->child[source[i]-'a']!=0)
        {
            current=current->child[source[i]-'a'];
            current->n=current->n+1;
        }
        else
        {
            newnode=(struct dictree *)malloc(sizeof(struct dictree));
            for(j=0;j<26;j++)
                newnode->child[j]=0;
            current->child[source[i]-'a']=newnode;
            current=newnode;
            current->n=1;
        }
    }
}
int find(char *source)
{
    int i,len;
    struct dictree *current;
    len=strlen(source);
    if(len==0) return 0;
    current=root;
    for(i=0;i<len;i++)
    {
        if(current->child[source[i]-'a']!=0)
            current=current->child[source[i]-'a'];
        else return 0;
    }
    return current->n;
}
int main()
{
    char temp[11];
    int i,j;
    root=(struct dictree *)malloc(sizeof(struct dictree));
    for(i=0;i<26;i++)
        root->child[i]=0;
    root->n=2;
    while(gets(temp),strcmp(temp,"")!=0)
        insert(temp);
    while(scanf("%s",temp)!=EOF)
    {
        i=find(temp);
        printf("%d\n",i);
    }
}


目录
相关文章
|
7月前
HDU-2089-不要62
HDU-2089-不要62
33 0
|
7月前
|
Java
HDU-4552-怪盗基德的挑战书
HDU-4552-怪盗基德的挑战书
42 0
|
Java
hdu 2503 a/b + c/d
hdu 2503 a/b + c/d
47 0
|
Java
hdu 1257 最少拦截系统
hdu 1257 最少拦截系统
51 0
|
人工智能 Java
2021杭电多校5-Arrary-hdu7020
Array Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others) Total Submission(s): 965 Accepted Submission(s): 312 Problem Description Given an integer array a[1…n].
180 0
2021杭电多校5-Arrary-hdu7020
HDU 2669 Romantic
题意:找出最小的非负整数X,使之满足式子X*a + Y*b = 1。
110 0