HDU1702

简介: ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1789    Accepted Submission(s): 963 Problem Description

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1789    Accepted Submission(s): 963


Problem Description
ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input
 
 
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
 
 
1 2 2 1 1 2 None 2 3
 

Source
#include <queue>
#include <stack>
#include <string>
#include<stdio.h>
#include<iostream>
using namespace std;

int main()

{    int t,n,temp,i;

    scanf("%d",&t);

    while(t--)

    {    string str,str1;

        queue<int>Q;
        stack<int>S;
        scanf("%d",&n);
        cin>>str;
        for(i=0; i<n; i++)
        {    if(str=="FIFO")
            {    cin>>str1;
                if(str1=="IN")
                {    scanf("%d",&temp);
                    Q.push(temp);
                }
                if(str1=="OUT")
                {    if(Q.empty())
                        printf("None\n");
                    else      {
                        printf("%d\n",Q.front());
                        Q.pop();
                    }
                }
            }            else
            {    cin>>str1;
                if(str1=="IN")
                {    scanf("%d",&temp);
                    S.push(temp);
                }
                if(str1=="OUT")
                {    if(S.empty())
                        printf("None\n");
                    else {
                        printf("%d\n",S.top());
                        S.pop();
                    }
                }
            }
        }
    }
    return 0;
}


目录
相关文章
|
7月前
HDU-2089-不要62
HDU-2089-不要62
33 0
|
算法 Java 人工智能
|
定位技术
hdu 4771 Stealing Harry Potter's Precious
点击打开链接 题意:题目给定一个n*m的地图,地图有一个起点标记为'@',还有'#'表示不能够走的,'.'表示可以走。给定k个点,问从起点开始把这k个点走过去的最小步数。
793 0
hdu 1856 More is better
点击hdu 1856思路: 思路: 离散化+并查集 分析: 1 点数最多为10^7,但是边数最多10^5,所以我们必须采用离散化,然后利用带权并查集的思想,rank[x]表示的是以x为根节点的集合的元素个数 2 这一题主要注意的就是当...
828 0
|
人工智能
HDU1106
为了给学弟学妹讲课,我又水了一题…… 1: import java.util.*; 2: import java.io.*; 3: 4: public class HDU1106 5: { 6: public static void main...
879 0