更新Joomla时应了解的8个因素-阿里云开发者社区

开发者社区> 开发与运维> 正文

更新Joomla时应了解的8个因素

简介: Joomla更新对于确保您的Joomla网站安全,更新Joomla的新功能,安全修复,改进和错误修复至关重要。更新Joomla版本很简单,但是在进行更新时您应注意一些重要因素。

Joomla更新对于确保您的Joomla网站安全,更新Joomla的新功能,安全修复,改进和错误修复至关重要。更新Joomla版本很简单,但是在进行更新时您应注意一些重要因素。

joomla-updates-notes.jpg

在此博客文章中,我们希望为您列出在更新Joomla 3的新版本时的重要因素。

1. Joomla 3.x的技术要求
推荐5.6 +或7 + [1]
PHP(Magic Quotes GPC,MB字符串过载=关闭/ Zlib压缩支持,XML支持,INI解析器支持,JSON支持,Mcrypt支持,MB语言=默认)
memory_limit - Minimum: 64M,推荐值:128M或更高
upload_max_filesize - Minimum: 20M
post_max_size - Minimum: 20M
max_execution_time:至少120推荐:300
您可以从Joomla网站管理面板>系统信息中查看当前的系统信息,以查看其是否符合Joomla 3要求。

joomla-updates-notes2.jpg

2.模板与新版本的兼容性:
在更新Joomla之前,您需要检查用于网站的模板是否与新版本兼容。如果它不支持新的Joomla版本,则升级后您的网站布局和样式可能会损坏甚至无法正常工作。

要求模板提供者升级模板
您自己更新模板
使用其他模板。当然,您将需要更新网站的布局和样式
如何检查您的模板是否与新的Joomla版本兼容?

joomla-updates-notes3.jpg

检查您网站上安装的模板版本。
检查模板的安装版本是否已准备好最新的Joomla
如果尚未准备好安装可用于Joomla的模板的最新版本,或等待模板更新

3.与新版本的扩展兼容性
与模板相同,要更新到新的Joomla版本,您需要确保您用于网站的所有扩展名都与新的Joomla版本兼容。

在更新之前,您需要检查使用了哪些扩展名,未使用哪些扩展名。

卸载所有不用于保持网站清洁的扩展。
要使用扩展名,请更新至最新版本。

4.完整备份站点
joomla-updates-notes4.jpg

在更新Joomla之前,请始终对网站进行完整备份。
您可以使用Akeeba Backup扩展名进行备份。
切勿在实时站点上播放更新,如果在更新Joomla后出现任何问题,站点备份将保存您的站点

5. Joomla更新:
joomla-updates-notes5.jpg

6. Joomla更新时出现错误:
joomla-updates-notes6.jpg

检查网站上的文件和文件夹权限(644和755)
检查您的互联网连接是否可以下载并安装Joomla更新

7.清除缓存
joomla-updates-notes7.jpg

更新您的Joomla Clear浏览器和Joomla缓存后,Joomla具有内置选项来清除缓存

8.检查所有功能
检查网站前端是否正在运行

检查您正在使用的扩展程序是否正常工作

检查Joomla管理功能是否像“文章/菜单/模块保存”一样工作

修复数据库

有时,更新Joomla后网站上会出现数据库错误。为了修复它们,Joomla提供了一个内置选项。

转到扩展>管理器>数据库>修复
如果发现任何错误,请单击“修复”

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章