Linux中composer install执行报错Warning: putenv() has been disabled for security reasons in 解决问题-阿里云开发者社区

开发者社区> 开发与运维> 正文

Linux中composer install执行报错Warning: putenv() has been disabled for security reasons in 解决问题

简介: Linux中composer install执行报错Warning: putenv() has been disabled for security reasons in 解决问题

Linux中composer install执行报错Warning: putenv() has been disabled for security reasons in 解决问题

按提示是去掉禁用函数 putenv() ,但是去除了也无法成功。

除了这个函数一般还会提示:

 proc_open这个函数,也可以一并去。

依然如此提示是为啥,

踩坑,安装了宝塔 7.3 和7.2,修改了7.3 哪怕你的程序对应选择的是7.3 ,7.2也必须修改才会生效。

只要其他版本php在启动中就会影响,此问题蛋疼耗费几个小时。
3.png

因为这是非常蛋疼的问题,必须记一下,太坑浪费时间。

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章