PrestaShop 1.7.6 在访问分类的时候提示错误-阿里云开发者社区

开发者社区> 开发与运维> 正文

PrestaShop 1.7.6 在访问分类的时候提示错误

简介:

PrestaShop 1.7.6 在访问分类的时候提示内部错误。

当打开 Debug 模式的时候,提示的错误是 mb_split 方法不能全局调用的错误。

2020_05_10_0_06_15

从错误提示上来看,你应该是在 PHP 中没有安装 mbstring 这个扩展。

如果你使用的是 CentOS 的话,你可以使用命令:

yum install php-mbstring 进行安装。

各种语言都有自己的编码,他们的字节数是不一样的,mbstring扩展就是为确保不同编码的语言在PHP程序中能够正常显示提供解决方案。

mbstring扩展库用于处理多字节字符串,对PHP来说很重要的。

不同字符编码,其在内存占用的字节数不一样。如ASCII编码字符占用1个字节,UTF-8编码的中文字符是3字节,GBK为2个字节 **

原因:*PHP不支持UNICODE,只有PHP变量支持中文,PHP变量的命名规则是a-zA-Z_x7f-xff,这个只是字符集的一部分,如果是unicode,就没必要限定这个范围了。

https://www.cwiki.us/display/PrestaShop/questions/62619727

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章