svnant不支持svn版本1.7-阿里云开发者社区

开发者社区> 小柒2012> 正文

svnant不支持svn版本1.7

简介:
+关注继续查看

看了标题进来的吧,话说事情是这个样子的。以前SVN服务版本是1.6,svnant版本是1.3.1,官网明确说明只支持到1.6.x。由于升级了SVN版本到1.7,然后问题就来了。

svnant官网:http://subclipse.tigris.org/svnant.html

123

源自国外网站的问题:
http://stackoverflow.com/questio ... o/11558376#11558376

我使用tortoise svn,最近我更新到1.7版本。仍然,在我们的构建系统(ant脚本)中,我们使用svnant lib(获取当前版本号,我们使用它作为版本号)。所以不能再构建项目,因为svnant不支持1.7版本的svn。我如何解决这个问题?

先谢谢你!

答案大致说了三种实现方式:
svnkit版本地址:https://svnkit.com/download.php

谷歌开源版本:https://github.com/opticyclic/svntask

以上2种方式本人都没有测试成功。

测试成功的方法如下:

svnant现已在源中更新以支持SVN 1.7,但您需要自己构建它。
在命令提示符下:
检查svnant到本地目录(用户名guest,空密码):
svn co http://subclipse.tigris.org/svn/subclipse/trunk/svnant/ svnant —username=guest

CD进入根svnant目录执行一下命令
ant makeDistrib

生成的JAR包一般会在这个目录 C:UsersAdministratorsvnantbuilddistriblib

然后把JAR包放到apache-ant目录的lib下面、xml脚本引入即可。
内联属性,如svnkit =“false” javahl=”false” 已经废弃,所以你将需要更新的描述使用svnSetting

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
ant的log4j2版本的Listener
点击(此处)折叠或打开 /* * Licensed to the Apache Software Foundation (ASF) under one or more * contributor license agreements.
575 0
Antd V4版本中Form resetFields无效
Antd V4版本中Form resetFields无效
91 0
PicGo v1.6版本更新——支持阿里云OSS
PicGo v1.6版本更新——支持阿里云OSS
4476 0
版本控制工具之SVN
虽然现在很多用git,但是SVN也是之前一代的神
799 0
使用OpenApi弹性释放和设置云服务器ECS释放
云服务器ECS的一个重要特性就是按需创建资源。您可以在业务高峰期按需弹性的自定义规则进行资源创建,在完成业务计算的时候释放资源。本篇将提供几个Tips帮助您更加容易和自动化的完成云服务器的释放和弹性设置。
12062 0
+关注
小柒2012
一个程序员,欢迎骚扰!!!
153
文章
2331
问答
文章排行榜
最热
最新