linux下eclipse闪退和重装jdk的方法

简介: 版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq1010885678/article/details/43577801 安装eclipse:(1)把eclipse-java-helios-SR2-linux-gtk.
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq1010885678/article/details/43577801

安装eclipse:

(1)把eclipse-java-helios-SR2-linux-gtk.tar.gz解压到某个目录中,我解压到的


是/usr/eclipse,得到eclipse目录
(2)在/usr/bin目录下创建一个启动脚本eclipse,执行下面的命令来创建:
vi /usr/bin/eclipse
然后在该文件中添加以下内容:
#!/bin/sh
export MOZILLA_FIVE_HOME="/usr/lib/mozilla/"
export ECLIPSE_HOME="/usr/eclipse"
$ECLIPSE_HOME/eclipse $*
(3)修改该脚本的权限,让它变成可执行,执行下面的命令:
sudo chmod +x /usr/bin/eclipse
 
在Applications(应用程序)菜单上添加一个图标
vi /usr/share/applications/eclipse.desktop
然后在文件中添加下列内容:
[Desktop Entry]
Encoding=UTF-8
Name=Eclipse Platform
Comment=Eclipse IDE
Exec=eclipse
Icon=/usr/eclipse/icon.xpm
Terminal=false
StartupNotify=true
Type=Application
Categories=Application;Development;

以上配置注意自己安装eclipse的路径


在linux虚拟机中安装eclipse编写java代码

一开始没啥异常,但是一使用智能提示功能或者其他什么原因eclipse会闪退

网上找了N久的办法终于解决

linux中装的jdk是最新的1.8

重新安装了1.6的jdk

之后在eclipse安装目录中编辑eclipse.ini

加入以下几句话保存

-Dorg.eclipse.swt.browser.DefaultType=mozilla
-Dorg.eclipse.swt.browser.UseWebKitGTK=true
-Dorg.eclipse.swt.browser.XULRunnerPath==/usr/lib/xulrunner-2

重启eclipse问题解决


重装jdk:

使用

rpm -qa | grep jdk
rpm -qa | grep gcj

查看具体的版本号

确定版本号之后使用

rpm -e --nodeps java-1.4.2-gcj-compat-1.4.2.0-40jpp.115

卸载

完成之后可以用java -version检查


之后下载jdk1.6版本

在usr目录下新建java文件件

mkdir /usr/java

修改jdk文件权限

chmod 755 jdk-6u11-linux-i586.bin 

执行jdk文件

./jdk-6u11-linux-i586.bin

完成之后配置环境变量

vi /etc/profile

加入以下内容

export JAVA_HOME=/usr/java/jdk
export PATH=$PATH:$JAVA_HOME/bin


使用. /etc/profile使其生效

在用java -version就可以看到新的jdk版本了


相关文章
|
1月前
|
Java Linux
Linux(服务器) 装JDK
Linux(服务器) 装JDK
43 1
|
8天前
|
算法 Java 数据安全/隐私保护
eclipse导入BASE64Encoder类的方法
eclipse导入BASE64Encoder类的方法
9 1
|
16天前
|
Ubuntu Java Linux
Linux centos7 ubuntu 一键安装Java JDK 脚本 shell 脚本
Linux centos7 ubuntu 一键安装Java JDK 脚本 shell 脚本
|
1天前
|
Java Linux
杨校老师课堂之CentOS7部署开发环境Jdk1.8【Linux】
杨校老师课堂之CentOS7部署开发环境Jdk1.8【Linux】
8 0
|
13天前
蓝易云 - MyEclipse6.5安装m2eclipse方法
注意:由于MyEclipse 6.5是一个较旧的版本,可能无法支持最新版本的m2eclipse插件,因此在下载时,请尽量选择与MyEclipse 6.5兼容的m2eclipse版本。
6 0
|
14天前
|
Java
JavaSE——JDK8新特性(2/2):方法引用(静态方法的引用、实例方法的引用、特定类型的方法引用、构造器引用)
JavaSE——JDK8新特性(2/2):方法引用(静态方法的引用、实例方法的引用、特定类型的方法引用、构造器引用)
9 0
|
16天前
|
Ubuntu Java Linux
Ubuntu20.04下载jdk遇到各种奇怪问题大集,Linux如何将默认的OpenJDK切换成自己安装的JDK版本(以JDK1.8为例),无需卸载原有OpenJDK,Some packages co
Ubuntu20.04下载jdk遇到各种奇怪问题大集,Linux如何将默认的OpenJDK切换成自己安装的JDK版本(以JDK1.8为例),无需卸载原有OpenJDK,Some packages co
|
1月前
|
关系型数据库 MySQL Java
Linux 安装 JDK、MySQL、Tomcat(图文并茂)
Linux 安装 JDK、MySQL、Tomcat(图文并茂)
55 2
|
1月前
|
Java Linux
Jdk的安装(Linux版)
Jdk的安装(Linux版)
30 1
|
1月前
|
Oracle Java 关系型数据库
Linux系统安装JDK
Linux系统安装JDK
41 1