POJ-1032-拆数字

简介: Description New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided in...

Description

New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input

The input file contains a single integer N (5<=N<=1000 ).

Output

Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.

Sample Input

7

Sample Output

3 4
题目大意:
将整数n,(5<=n<=1000)拆成多个不相等的数(和),使所以有的数之积最大。
思路;
一个数n入能被2 整除,则(n/2)*(n/2)最大;若不能则(n/2)*(n/2+1)最大
所以启发:把一个数从小的开始分,把剩余的部分分别加到后面大数上
所有数开始拆:
例如 7:先拆成:2 3 剩余2 ,分别让2,3加1,得3 4;
例如 8:拆成2 3 剩余3;分别让2 3 加1 ,还余1;让3加1再加1;得3 5;
例如 9 :直接拆成2 3 4;
#include<iostream>
using namespace std;
int main()
{

    int n,s=0,a[100]={0};
    cin>>n;
    int i;
    for(i=2;s+i<=n;i++)//注意不能仅仅让s<=n;这样会导致多循环一次
    {
      a[i]=i;
      s+=i;
    }

    int h=i;
    for(int j=n-s;j>0;j--)//把剩余的即n-s部分从数组最后往前均分
    {
        a[--i]++;
        if(i==2)i=h;//第一遍均分后让i回到最后再开始均分

    }
for(int k=2;k<h;k++)
{
    cout<<a[k]<<" ";
}
    return 0;
}

  

相关文章
|
7月前
【每日一题Day297】LC1444切披萨的方案数 | 动态规划+二维前缀和
【每日一题Day297】LC1444切披萨的方案数 | 动态规划+二维前缀和
73 0
|
定位技术
【CCCC】L3-007 天梯地图 (30分),两次Dijkstra+路径打印(数据点2,4错因),90行最短题解
【CCCC】L3-007 天梯地图 (30分),两次Dijkstra+路径打印(数据点2,4错因),90行最短题解
186 0
|
7月前
|
机器学习/深度学习 算法 测试技术
【动态规划】【子数组划分】【前缀和】1977. 划分数字的方案数
【动态规划】【子数组划分】【前缀和】1977. 划分数字的方案数
|
7月前
|
C语言
浙大版《C语言程序设计(第3版)》题目集 练习8-2 计算两数的和与差 (10分)
浙大版《C语言程序设计(第3版)》题目集 练习8-2 计算两数的和与差 (10分)
|
7月前
【每日一题Day257】LC2178拆分成最多数目的正偶数之和 | 贪心
【每日一题Day257】LC2178拆分成最多数目的正偶数之和 | 贪心
35 2
|
人工智能 算法
代码随想录算法训练营第三十五天 | LeetCode 435. 无重叠区间、763. 划分字母区间、56. 合并区间
代码随想录算法训练营第三十五天 | LeetCode 435. 无重叠区间、763. 划分字母区间、56. 合并区间
71 0
|
算法
7-1 哈夫曼编码 (30分)
7-1 哈夫曼编码 (30分)
554 0
|
机器学习/深度学习 C语言 C++
信奥赛一本通1150:求正整数2和n之间的完全数
题目描述】 求正整数2和n之间的完全数(一行一个数)。 完全数:因子之和等于它本身的自然数,如 6=1+2+3 【输入】 输入n(n≤5000)。 【输出】 一行一个数,按由小到大的顺序。 【输入样例】 7 【输出样例】
583 0
|
人工智能 BI
力扣刷题记录——561. 数组拆分、566. 重塑矩阵、575. 分糖果
力扣刷题记录——561. 数组拆分、566. 重塑矩阵、575. 分糖果
149 0
力扣刷题记录——561. 数组拆分、566. 重塑矩阵、575. 分糖果
|
算法
哈夫曼编码 (30 分)
哈夫曼编码 (30 分)
131 0