python安装scikit-image时出现错误:Operation not permitted-阿里云开发者社区

开发者社区> 微wx笑> 正文

python安装scikit-image时出现错误:Operation not permitted

简介: 版权声明:本文为 testcs_dn(微wx笑) 原创文章,非商用自由转载-保持署名-注明出处,谢谢。 https://blog.csdn.net/testcs_dn/article/details/81168591 python安装scikit-image时出现错误:Operation not permitted 错误信息超级多,得有个十几二十页吧,我就不贴了。
+关注继续查看
版权声明:本文为 testcs_dn(微wx笑) 原创文章,非商用自由转载-保持署名-注明出处,谢谢。 https://blog.csdn.net/testcs_dn/article/details/81168591

python安装scikit-image时出现错误:Operation not permitted

错误信息超级多,得有个十几二十页吧,我就不贴了。

解决方法:

sudo pip install scikit-image --user

之前是直接使用以下命令安装遇到的错误:

sudo pip install scikit-image

还有,使用pip的默认源安装时,下载特别慢,经常会超时。

解决方法:

pip-修改国内镜像源

mkdir ~/.pip 
vim ~/.pip/pip.conf
[global]
index-url = http://mirrors.aliyun.com/pypi/simple/
[install]
trusted-host = mirrors.aliyun.com

注意事项:

  1. http://mirrors.aliyun.com/pypi/simple/中的simple目录必须有。
  2. --no-cache-dir重新下载安装包,而不是使用缓存包。
  3. trusted-host = mirrors.aliyun.com一定要加上这行,否则会报错。
  4. pip国内镜像源。

    阿里云 http://mirrors.aliyun.com/pypi/simple/
    中国科技大学 https://pypi.mirrors.ustc.edu.cn/simple/
    豆瓣 http://pypi.douban.com/simple
    Python官方 https://pypi.python.org/simple/
    v2ex http://pypi.v2ex.com/simple/
    中国科学院 http://pypi.mirrors.opencas.cn/simple/
    清华大学 https://pypi.tuna.tsinghua.edu.cn/simple/

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
处理程序“PageHandlerFactory-Integrated”在其模块列表中有一个错误模块“ManagedPipelineHandler”
server2008  iis7,出错上面的错误 . 提示的原因可能是net未完整安装导致的. 解决方法:  1、开始->运行cmd命令窗->以管理员身份运行: %windir%\Microsoft.
903 0
Python数据科学安装Numby,pandas,scipy,matpotlib等(IPython安装pandas)
Python数据科学安装Numby,pandas,scipy,matpotlib等(IPython安装pandas) 如果还没有本地安装Python、IPython、notebook等请移步 上篇 Python,IPython,qtconsole,Notebook,Jupyter快速安装教程 本教程是安装二进制文件,以Windows10 64位操作系统为例,
1746 0
PHP错误:Forbidden You don't have permission to access / on this server.
原文:PHP错误:Forbidden You don't have permission to access / on this server. 今天老大让在xp下搭建一个FTP服务器,一波三折,最后终于在老大的帮助下搞定了。
1345 0
jdk版本冲突Unsupported major.minor version错误定位
java中编译代码时,如果因jdk版本不同,可能导致编译失败,下面我提供一个我解决此类问题的思路供大家参考
3628 0
Linux系统下安装rz/sz命令及使用说明
 对于经常使用Linux系统的人员来说,少不了将本地的文件上传到服务器或者从服务器上下载文件到本地,rz / sz命令很方便的帮我们实现了这个功能,但是很多Linux系统初始并没有这两个命令。
992 0
mybatis 错误apped Statements collection does not contain value for
apped Statements collection does not contain value for后面是什么类什么方法之类的: 错误原因有几种: 1、mapper.xml中没有加入namespace 2、mapper.xml中的方法和接口mapper的方法不对应 3、mapper.xml没有加入到mybatis-config.xml中(即总的配置文件),例外:配置了mapper文
1377 0
+关注
微wx笑
无知人生,记录点滴。 不积跬步,无以至千里;不积小流,无以成江海…… 订阅号:微wx笑, 个人站点:https://www.ivu4e.com/, CSDN博客:https://blog.csdn.net/testcs_dn
1417
文章
1385
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载