1073. Scientific Notation (20) 棒棒的

简介: Scientific notation is the way that scientists easily handle very large numbers or very small numbers.

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

Sample Input 1:
+1.23400E-03
Sample Output 1:
0.00123400
Sample Input 2:
-1.2E+10
Sample Output 2:
-12000000000

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    string s, sc, se;
    cin >> s;
    
    for (int i = 0; i < s.length(); i++) {
        if (s[i] == 'E') {
            sc = s.substr(0, i);
            se = s.substr(i+1, s.length());
            break;
        }
    }
    
    char fc = sc[0], fe = se[0];
    int n = stoi(se.substr(1, se.length()));
    
    string t = "";
    for (int i = 1; i < sc.length(); i++) {
        if (sc[i] != '.') {
            t += sc[i];
        }
    }
    
    if (fc == '-') {
        cout << fc;
    }
    if (fe == '+') {
        if (n < t.length() - 1) {
            for (int i = 0; i < t.length(); i++) {
                cout << t[i];
                if (i == n) {
                    cout << '.';
                }
            }
            cout << endl;
        }else if(n == t.length()){
            cout << t << endl;
        }else{
            cout << t;
            for (int i = 0; i < n - t.length() + 1; i++) {
                cout << 0;
            }
            cout << endl;
        }
    }else{
        if (n == 1) {
            cout << "0." << t << endl;
        }else{
            cout << "0.";
            for (int i = 0; i < n - 1; i++) {
                cout << 0;
            }
            cout << t << endl;
        }
    }

    return 0;
}


目录
相关文章
|
5天前
|
存储 程序员 编译器
Modern C++
Modern C++
|
11月前
|
C++
【PAT甲级 - C++题解】1073 Scientific Notation
【PAT甲级 - C++题解】1073 Scientific Notation
50 0
【1073】Scientific Notation (20 分)
【1073】Scientific Notation (20 分)【1073】Scientific Notation (20 分)
77 0
|
Java Go Kotlin
For an experienced software engineer, what would be a preferred new programming language to learn?
For an experienced software engineer, what would be a preferred new programming language to learn? Chanaka Fernando, knows Sin...
1090 0