1129 recommendation system set

简介: Recommendation system predicts the preference that a user would give to an item.

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] … rec[K]

where query is the item that the user is accessing, and rec[i] (i = 1, … K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

#include <iostream>
#include <set>
#include <algorithm>
using namespace std;
int book[50001];//存储cnt
//思路:采用在线处理 每输入一个数字 遍更新其频率并再排序输出(set会根据大小自动排序)
struct node{
    int value;
    int cnt;
    bool operator < (const node &a) const {//运算符重载
        return (cnt != a.cnt) ? cnt > a.cnt : value < a.value;
    }
};

int main(){
    int n, k, t;
    cin >> n >> k;
    set<node> s;
    for (int i = 0; i < n; i++) {
        cin >> t;
        if (i) {
            printf("%d:", t);
            int c = 0;
            for (auto it = s.begin(); c < k && it != s.end(); it++) {
                printf(" %d", it->value);
                c++;
            }
            printf("\n");
        }
        //删除这个元素 将cnt+1后 再把这个元素插入set  set在插入时会自动排序
        auto it = s.find(node{t, book[t]});
        if (it != s.end()) s.erase(it);
        book[t]++;
        s.insert(node{t, book[t]});
    }
    return 0;
}
目录
相关文章
|
5月前
|
API Android开发 开发者
failed to set system property error code: 0x18
failed to set system property error code: 0x18
189 1
|
5月前
|
关系型数据库 PostgreSQL
PostgreSQL 的哪些参数不能通过ALTER SYSTEM SET 修改
在 PostgreSQL 中,有一些参数是不能通过 `ALTER SYSTEM SET` 语句进行动态修改的,这些参数通常需要在 PostgreSQL 的配置文件中进行手动修改。以下是一些不能通过 `ALTER SYSTEM SET` 修改的常见参数: 1. **track_activities** 2. **track_counts** 3. **track_io_timing** 4. **track_functions** 5. **track_activity_query_size** 6. **track_commit_timestamp** 7. **shared_preload
104 0
|
Java Maven
Maven常见问题之【-Dmaven.multiModuleProjectDirctory system property is not set】
-----------------------哇,下面就是解决方案
5006 0
|
Java Maven
-Dmaven.multiModuleProjectDirectory system propery is not set.
Myeclipse中使用maven插件的时候,运行run as maven build的时候报错 -Dmaven.multiModuleProjectDirectory system propery is not set.
1015 0
|
Java
【JAVA秒会技术之异常解决】Dmaven.multiModuleProjectDirectory system propery is not set
maven启动时报错: Dmaven.multiModuleProjectDirectory system propery is not set. Check $M2_HOME environment variable and mvn script match. 添加如下参数: -Dmaven.multiModuleProjectDirector
996 0
|
SQL Oracle 关系型数据库
【OH】SET System Variable Summary SQLPLUS 系统变量设置
SET System Variable Summary System Variable Description ...
1505 0
下一篇
无影云桌面