ssh(安全外壳协议)-阿里云开发者社区

开发者社区> 开发与运维> 正文

ssh(安全外壳协议)

简介: SSH 为 Secure Shell 的缩写,由 IETF 的网络工作小组(Network Working Group)所制定;SSH 为建立在应用层和传输层基础上的安全协议。SSH 是目前较可靠,专为远程登录会话和其他网络服务提供安全性的协议。

SSH 为 Secure Shell 的缩写,由 IETF 的网络工作小组(Network Working Group)所制定;SSH 为建立在应用层和传输层基础上的安全协议。SSH 是目前较可靠,专为远程登录会话和其他网络服务提供安全性的协议。利用 SSH 协议可以有效防止远程管理过程中的信息泄露问题。SSH最初是UNIX系统上的一个程序,后来又迅速扩展到其他操作平台。SSH在正确使用时可弥补网络中的漏洞。SSH客户端适用于多种平台。几乎所有UNIX平台—包括HP-UXLinuxAIXSolarisDigital UNIXIrix,以及其他平台,都可运行SSH。

 

ubuntu中进行安装

buntu默认并没有安装ssh服务,如果通过ssh链接ubuntu,需 要自己手动安装ssh-server,然而SSH分客户端openssh-client和服务端openssh-server,openssh- client是客户端,openssh-server是服务端,

咱们这里讲的是安装SSH的服务端,即:openssh-server。

 

判断咱们的机器是否安装ssh服务,可以使用如下命令:

ssh localhost
ssh: connect to host localhost port 22: Connection refused

 

这个就表示没有还没有安装SSH,

 

安装命令:sudo apt-get install openssh-server

卸载命令:sudo apt-get remove openssh-server

咱们运行 sudo apt-get install openssh-server 命令之后,确认下是否安装正常

 

ps -e|grep ssh  

1418 ?        00:00:00 sshd 

 

看到sshd那说明ssh-server已经启动了

如果没有则可以这样启动:sudo /etc/init.d/ssh start 或者 service ssh start


 之前因为实验安装SSH,安装又卸载后却提 示:E:unable to locate package opensshE:unable to locate package server这个是 警告是说明本机没有找到openssh的安装包,之前能安装说明SSH包是存在的,而卸载后却提示找不到SSH包,说明很可能是运行卸载后,直接删除掉 了,那么我们现在需要升级下sudo apt-get update,然后再安装试试还是不行。然后网上找了下说是更新了软件源,需要更新并且安装后才能 使用 安装更新
sudo apt-get dist-upgrade

 

如果需要新加用户进行连接

新加用户  adduser test  这时会要求你填写密码,也可以切换到要修改密码的用户,然后使用passwd进行修改密码

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章