Pythonxy Spyder Errors-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

Pythonxy Spyder Errors

简介:  Spyder提示ValueError: API ‘QString’ has already been set to version 1 问题出在import这里, 1 from enthought.mayavi import mlab 因为Enthought在调用PyQt时使用的是API #2,而Spyder默认使用API #1,把他改为API #2即可。

 Spyder提示ValueError: API ‘QString’ has already been set to version 1

问题出在import这里,

1
from enthought.mayavi import mlab

因为Enthought在调用PyQt时使用的是API #2,而Spyder默认使用API #1,把他改为API #2即可。
打开Tools -> Preferences,左边选择Console,右边打开External modules选项卡,在下面找到PyQt,把里面的API selection for QString and QVariant object:改为API #2,确定,再次运行时就正常了。


版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章
最新文章
相关文章