Box of Bricks

简介:

Box of Bricks

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1450 Accepted Submission(s): 335
Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I\'ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
 
Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
 
Output

            For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.
 
Sample Input
6
5 2 4 1 7 5
0
 
Sample Output
Set #1
The minimum number of moves is 5.
  • Code Render Status : Rendered By HDOJ G++ Code Rander Version 0.01 Beta
#include <iostream>
#include "string.h"
using namespace std;
int main()
{
  int set=0,num,hi[101],total,mv;
    while( cin>>num&&num!=0)
    {
        mv = 0 ;
        total = 0 ;
        memset(hi,0,sizeof(hi));

         for(int i = 0 ; i < num ; i++)
      {
          cin>>hi[i];
          total +=hi[i];
      }
      int k = total/num;
      for(int i = 0 ; i < num ; i++)
      {
          if(hi[i]>k) mv += (hi[i]-k);
      }
      set++;
      cout<<"Set #"<<set<<endl;
      cout<<"The minimum number of moves is "<<mv<<"."<<endl<<endl;
    }
      return 0;
}







本文转自NewPanderKing51CTO博客,原文链接:http://www.cnblogs.com/newpanderking/archive/2011/07/23/2114932.html ,如需转载请自行联系原作者



相关文章
|
2月前
|
机器学习/深度学习 计算机视觉 索引
bounding box
【9月更文挑战第14天】
26 3
|
1月前
|
前端开发 容器
box—sizing 属性的了解
box—sizing 属性的了解
45 0
|
1月前
|
前端开发
box-sizing属性
box-sizing属性
23 0
|
1月前
|
前端开发
content-box和border-box是什么?
content-box和border-box是什么?
82 0
|
1月前
|
前端开发 开发者 容器
CSS3:flex&box-sizing
本文介绍了CSS中的Flex布局及其相关属性,如`flex-direction`、`flex-wrap`、`justify-content`等,并通过代码示例展示了如何使用这些属性来控制容器内的项目排列方式。同时,还讲解了`align-items`属性用于定义子元素在交叉轴上的对齐方式,以及`box-sizing`属性的不同取值对元素尺寸计算的影响。
|
2月前
box-sizing属性值
box-sizing属性值。
26 13
|
2月前
box-shadow属性
box-shadow属性。
102 8
|
6月前
|
前端开发
CSS:为什么看起来content-box更合理,但还是经常使用border-box?
CSS:为什么看起来content-box更合理,但还是经常使用border-box?
117 2
|
6月前
|
前端开发
如何将一个盒子模型变成border-box?
如何将一个盒子模型变成border-box?
39 0
|
6月前
|
前端开发
对box-sizing的了解
对box-sizing的了解
73 0