Leftmost Digit

简介:

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 453 Accepted Submission(s): 229
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

int main()
{
    int num;
    double t,l,m;
    long long int N;
    cin>>num;
    while(num--)
    {
         cin>>N;
         t = N*log10(N);
         l = t - (long long int)t;
         m = pow(10,l);
        cout<<(int)m<<endl;
    }
    return 0;
}














相关文章
|
12月前
1212:LETTERS
1212:LETTERS
|
8月前
|
机器学习/深度学习
hdu 1061 Rightmost Digit
hdu 1061 Rightmost Digit
18 0
LeetCode 233. Number of Digit One
给定一个整数 n,计算所有小于等于 n 的非负整数中数字 1 出现的个数。
66 0
LeetCode 233. Number of Digit One
Anton and Letters
Anton and Letters
92 0
Anton and Letters
HDOJ 1197 Specialized Four-Digit Numbers
HDOJ 1197 Specialized Four-Digit Numbers
89 0
[LeetCode]--400. Nth Digit
Find the nth digit of the infinite integer sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, … Note: n is positive and will fit within the range of a 32-bit signed integer (n &lt; 231). Exampl
1183 0
|
机器学习/深度学习
[LeetCode]--172. Factorial Trailing Zeroes
Given an integer n, return the number of trailing zeroes in n!. Note: Your solution should be in logarithmic time complexity. Credits: Special thanks to @ts for adding this problem and c
1036 0