Leftmost Digit

简介:

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 453 Accepted Submission(s): 229
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

int main()
{
    int num;
    double t,l,m;
    long long int N;
    cin>>num;
    while(num--)
    {
         cin>>N;
         t = N*log10(N);
         l = t - (long long int)t;
         m = pow(10,l);
        cout<<(int)m<<endl;
    }
    return 0;
}














相关文章
|
Java
Leetcode 3. Longest Substring Without Repeating Characters
此题题意是找出一个不包含相同字母的最长子串,题目给出了两个例子来说明题意,但这两个例子具有误导性,让你误以为字符串中只有小写字母。还好我是心机boy,我把大写字母的情况也给考虑进去了,不过。。。。字符串里竟然有特殊字符,于是贡献了一次wrong answer,这次我把ascii字符表都考虑进去,然后就没问题了。这个故事告诫我们在编程处理问题的时候一定要注意输入数据的范围,面试中可以和面试官去确认数据范围,也能显得你比较严谨。
65 3
|
机器学习/深度学习
hdu 1061 Rightmost Digit
hdu 1061 Rightmost Digit
40 0
LeetCode 233. Number of Digit One
给定一个整数 n,计算所有小于等于 n 的非负整数中数字 1 出现的个数。
102 0
LeetCode 233. Number of Digit One
|
算法
LeetCode 423. Reconstruct Original Digits
给定一个非空字符串,其中包含字母顺序打乱的英文单词表示的数字0-9。按升序输出原始的数字。
127 0
LeetCode 423. Reconstruct Original Digits
|
机器学习/深度学习
HDOJ 1061 Rightmost Digit(循环问题)
HDOJ 1061 Rightmost Digit(循环问题)
134 0
HDOJ 1061 Rightmost Digit(循环问题)
HDOJ 1197 Specialized Four-Digit Numbers
HDOJ 1197 Specialized Four-Digit Numbers
117 0
|
算法
[LeetCode]--3. Longest Substring Without Repeating Characters
Given a string, find the length of the longest substring without repeating characters. Examples: Given “abcabcbb”, the answer is “abc”, which the length is 3. Given “bbbbb”, the answer i
1473 0