poj 1656 Counting Black(模拟)

简介:
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9101   Accepted: 5879

Description

There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100). 

We may apply three commands to the board: 

1. WHITE x, y, L // Paint a white square on the board,
// the square is defined by left-top grid (x, y)
// and right-bottom grid (x+L-1, y+L-1)

2. BLACK x, y, L // Paint a black square on the board,
// the square is defined by left-top grid (x, y)
// and right-bottom grid (x+L-1, y+L-1)

3. TEST x, y, L // Ask for the number of black grids
// in the square (x, y)- (x+L-1, y+L-1)

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied.

Input

The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won't try to paint/test the grids outside the board.

Output

For each TEST command, print a line with the number of black grids in the required region.

Sample Input

5
BLACK 1 1 2
BLACK 2 2 2
TEST 1 1 3
WHITE 2 1 1
TEST 1 1 3

Sample Output

7
6
复制代码
#include <iostream>
#define MAXNUM 101
using namespace std;

int point[MAXNUM][MAXNUM];//标记格子颜色

int main()
{
    int t;//t种情况
    //(x y)左上坐标 (x1,y1)右下坐标 num:记录黑色数目
    int x,y,x1,y1,l,num;
    string s;//命令cmd
    cin>>t;//命令数目
    while(t--)
    {
        num = 0;
        cin>>s>>x>>y>>l;
        x1 = x+l-1;
        y1 = y+l-1;
        //黑色命令,把区域内的块设置为黑色:1
        if(s.compare("BLACK")==0)
        {
            for(int i = x; i <= x1; ++i)
            for(int j = y; j <= y1; ++j)
            {
                point[i][j] = 1;
            }
        }
        //白色命令,把区域内的块设置为白色:0
        else if(s.compare("WHITE")==0)
        {
            for(int i = x; i <= x1; ++i)
            for(int j = y; j <= y1; ++j)
            {
                point[i][j] = 0;
            }
        }
        //测试命令,输出黑色块的数目
        else if(s.compare("TEST")==0)
        {
            for(int i = x; i <= x1; ++i)
            for(int j = y; j <= y1; ++j)
            {
                if(point[i][j]==1)num++;
            }
            cout<<num<<endl;
        }
    }
    return 0;
}
复制代码

 











本文转自NewPanderKing51CTO博客,原文链接: http://www.cnblogs.com/newpanderking/archive/2012/09/08/2676961.html,如需转载请自行联系原作者



相关文章
|
8月前
light oj 1159 - Batman LCS
学过简单动态规划的人应该对最长公共子序列的问题很熟悉了,这道题只不过多加了一条字符串变成三条了,还记得,只要把状态变成三维的即可。
21 0
|
8月前
light oj 1231-1232 - 1233- Coin Change 背包
暂时到半懂不懂也没办法讲明白,就不误人子弟了,直接贴代码了。
23 0
|
8月前
Light oj 1112 - Curious Robin Hood(树状数组)
有n个数,有m组操作,1 i表示将第i个数先输出,然后置0, 2 i v 表示给第i个数加上v, 3 i j 表示求i 到 j 的和,注意,这里数组是从0开始的,而我们构造的树状数组是从1 开始的,使用在程序中要进行一定的处理。
28 0
|
8月前
|
算法
light oj 1047 - Neighbor House 动态规划
动态规划,这个和刘汝佳算法竞赛入门经典P158的数字三角形有些相似,不过是求最小的值,而且有些限制,每次走到点和上次走的点不在同一列。
19 0
|
8月前
|
机器学习/深度学习
light oj 1005 - Rooks(组合数学)
组合数学解法 现在n行中选出m行,C(n,m),再在n列中选出m列随便放A(n,m),答案为C(n,m)*A(n,m)。
23 0
|
10月前
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
|
测试技术
POJ3687---Labeling Balls
POJ3687---Labeling Balls
POJ3687---Labeling Balls
All in the Family_upc_模拟 or lca + 并查集
The scientists working at the Family Genetics Institute are tracing the spread of a hereditary disease through family trees. They have started by listing the family members that have the disease,
100 0
All in the Family_upc_模拟 or lca + 并查集