2、ROS实时检测在线IP数并自动对IP做限速-阿里云开发者社区

开发者社区> 云计算> 正文

2、ROS实时检测在线IP数并自动对IP做限速

简介:

1、将在线IP自动添加到地址列表

1.png

2.png

3.png

4.png


2、实时检测在线IP数

5.png

6.png

7.png

3、自动对IP做限速

8.png

9.png

10.png

实时检测在线IP数

:local s 0

:foreach i in=[/ip firewall address-list find list=Online] do={:set s ($s+1)}

:log warning ("当前" . $s . "个IP在线")



自动对IP做限速

:local s 0

:foreach i in=[/ip firewall address-list find list=Online] do={:set s ($s+1)}

:foreach i in=[/ip firewall address-list find list=Online] do={:local ip 0;set ip [:ip firewall address-list get $i address];if (/queue simple get [/queue simple find name=$ip] = "") do={:queue simple add max-limit=20M/6M name=$ip target=$ip;log warning ($ip."限速upload:20M,download:6M")}}




      本文转自开源殿堂 51CTO博客,原文链接:http://blog.51cto.com/kaiyuandiantang/2087081,如需转载请自行联系原作者


版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

其他文章